View Issue Details

IDProjectCategoryView StatusLast Update
0003691DraftBugpublic2019-02-04 10:35
ReporterJaneEAssigned Tochrisb 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionreopened 
Platform64 bitOSWindowsOS Version10 Home
Product Version0.17 
Target VersionFixed in Version 
Summary0003691: Draft Scale only scales up but not down
DescriptionWhen using "Draft Scale" on a shape all decimal points for scale vector ignored. I can only make shapes larger but not smaller than the original.
Steps To ReproduceCreate New Document
Select Draft Workspace
Create a Rectangle (or any other geometry)
Highlight the created Rectangle
Select "Draft Scale"
Choose point
In the scale task window any X, Y, Z factors changes "1" to any higher number works fine. But typing numbers less than 1 does not work (like 0.75). I have tried using "." and "," but none work.
TagsDraft

Activities

AbdeJong

2019-01-02 18:56

reporter   ~0012362

I am in a project that relies on scaling down and encounter the same problem (the alternative being importing scaled point clouds from Excel and making scaled BSplines). Is there an idea if and when this bug can be fixed. I prefer an internal FreeCAD solution because of the excellent posibilities to adapt earlier features.

Kunda1

2019-01-04 18:45

administrator   ~0012368

@JaneE and @AbdeJong please discuss this on the FC forum as per our guidelines (big yellow banner at the top of this bugtracker). Please make sure you also test this issue on the latest 0.18_pre version. Report back your findings please.

chrisb

2019-02-03 22:30

developer   ~0012580

Works as designed, OP might have set decimal places wrong.
Tested with
OS: Ubuntu 16.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15780 (Git)
Build type: Release
Branch: master
Hash: f94e76c1116ec3b818961ff65131b3d86fa5b95e
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

chrisb

2019-02-04 10:34

developer   ~0012581

Initial settings of a vanilla FreeCAD with 2 decimals do not apply to the scale dialog, where decimals are even more important as in length values. I can fix this by
- open Preferences
- open General->Units without changing anything!
- conform settings with ok

Now the scale dialog shows 6 decimals.

Corresponding forum discussion.

Issue History

Date Modified Username Field Change
2018-11-14 06:52 JaneE New Issue
2018-11-14 06:52 JaneE Tag Attached: Draft
2019-01-02 18:56 AbdeJong Note Added: 0012362
2019-01-04 18:45 Kunda1 Status new => feedback
2019-01-04 18:45 Kunda1 Note Added: 0012368
2019-02-03 22:30 chrisb Assigned To => chrisb
2019-02-03 22:30 chrisb Status feedback => closed
2019-02-03 22:30 chrisb Resolution open => no change required
2019-02-03 22:30 chrisb Note Added: 0012580
2019-02-04 10:34 chrisb Status closed => feedback
2019-02-04 10:34 chrisb Resolution no change required => reopened
2019-02-04 10:34 chrisb Note Added: 0012581
2019-02-04 10:35 chrisb Status feedback => new