View Issue Details

IDProjectCategoryView StatusLast Update
0003648FreeCADFeaturepublic2019-06-20 15:46
ReportervocxAssigned Totriplus 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.19 
Summary0003648: Allow the user to manually move the tabs in the main window
DescriptionWhen using a workbench like TechDraw each new Page creates a tab in the bottom of the viewport. When the model file is opened, all Pages are opened as well, cluttering the bottom of the viewport. There should be a way to define which TechDraw pages to load from the beginning, including none of them.

Also, it seems like all such tabs appear in the order that they were created and cannot be reordered. Reordering of tabs is a common feature of many modern programs. It is a desirable feature to logically structure the TechDraw Pages and views. In many cases the user creates pages and views, but then has to go back, delete some pages, and add others, and this produces Page tabs that aren't in order.

In this thread the need for manually arranging Pages from TechDraw is explained https://forum.freecadweb.org/viewtopic.php?f=35&t=31654

In this post it is shown that a simple tabbed window uses QTabWidgets that can be reordered. https://forum.freecadweb.org/viewtopic.php?f=35&t=31654#p263268

wandererfan comments that in FreeCAD this functionality resides in src/Gui/MainWindow.cpp, and it is not exposed to the workbenches, so the workbenches cannot change the way tabs behave.

The tabbed window and workspace seems to be created as QMdiArea*
https://github.com/FreeCAD/FreeCAD/blob/master/src/Gui/MainWindow.cpp#L242
Additional InformationOS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14995 (Git)
Build type: Release
Branch: master
Hash: 7b866816785ac1ca9787b63d4bff12873bb3a593
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.

Activities

uwestoehr

2019-05-12 21:22

developer   ~0013100

I also vote for this feature since this would improve the workflow a lot when dealing with several documents at once:
https://forum.freecadweb.org/viewtopic.php?f=8&t=36320

Kunda1

2019-06-20 03:17

administrator   ~0013272

See FreeCAD Pull Request 2273

Related Changesets

FreeCAD: master 54c6537a

2019-06-19 20:54:23

triplus


Committer: wmayer Details Diff
Set QMdiArea tabs movable Affected Issues
0003648
mod - src/Gui/MainWindow.cpp Diff File

Issue History

Date Modified Username Field Change
2018-10-22 22:06 vocx New Issue
2019-05-12 21:22 uwestoehr Note Added: 0013100
2019-06-20 03:17 Kunda1 Note Added: 0013272
2019-06-20 15:45 wmayer Changeset attached => FreeCAD master 54c6537a
2019-06-20 15:46 wmayer Assigned To => triplus
2019-06-20 15:46 wmayer Status new => closed
2019-06-20 15:46 wmayer Resolution open => fixed
2019-06-20 15:46 wmayer Fixed in Version => 0.19