View Issue Details

IDProjectCategoryView StatusLast Update
0003644TechDraw[FreeCAD] Bugpublic2018-10-26 12:08
Reportervocx Assigned Towandererfan  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003644: Rotated text doesn't keep rotation after closing TechDraw Page
DescriptionTechDraw_NewAnnotations have a property called Rotation to set the angle of the baseline of the annotation. If the TechDraw Page is closed the appearance of the annotation resets, and the text looks horizontal (not rotated).

Discussion and images in the forum https://forum.freecadweb.org/viewtopic.php?f=35&t=31656
Steps To ReproduceCreate a TechDraw Page, add an annotation and set the Rotation to 90 degrees; the annotation correctly rotates. Close the TechDraw Page, and open it again. The annotation looks like it has rotation 0. Its properties indicate the Rotation is 90, but it looks like it has Rotation 0. Just enter the value 90 again, to force the text to actually rotate.
Additional InformationOS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14979 (Git)
Build type: Release
Branch: master
Hash: 47536dcd3729d3db106af628d62f2bf449e68c49
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.
FreeCAD Information

Activities

wandererfan

2018-10-26 12:08

manager   ~0012094

commit 8280d55

wandererfan

2018-10-26 12:08

manager   ~0012095

closed

Issue History

Date Modified Username Field Change
2018-10-19 21:06 vocx New Issue
2018-10-26 12:08 wandererfan Status new => resolved
2018-10-26 12:08 wandererfan Resolution open => fixed
2018-10-26 12:08 wandererfan Fixed in Version => 0.18
2018-10-26 12:08 wandererfan Target Version => 0.18
2018-10-26 12:08 wandererfan Note Added: 0012094
2018-10-26 12:08 wandererfan Assigned To => wandererfan
2018-10-26 12:08 wandererfan Status resolved => closed
2018-10-26 12:08 wandererfan Note Added: 0012095