View Issue Details

IDProjectCategoryView StatusLast Update
0003639TechDraw[FreeCAD] Bugpublic2018-10-21 16:32
ReportermkeyAssigned Towandererfan 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003639: TechDraw Detail view stalls FreeCAD
DescriptionWhen adding a Detail view to a view created in TechDraw workbench for a spherical object (in this test case a simple cylinder, a pipe created with padding and a pipe created with a sweep) FreeCAD will hang every time the detail view is redrawn. That is, on opening the file, saving or changing some of the properties.

It seems that the cylinder causes a shorter hang than a pipe does.

The report view gives this message:

DVP::extractFaces - input is not planar graph. No face detection


The standard modus operandi is:

- cause the detail view to be rebuilt
- FC hangs with 100% usage on 1 CPU core for up to 70 seconds
- FC recovers and can be used normally until the next rebuild of the detail view
Steps To Reproduce1. create a new file
2. switch to PartDesign, create a new body, sketch
3. draw two concentric circles and constrain them
4. pad the sketch
5. switch to TechDraw
6. create a new drawing
8. add a new view
9. add a detail view of the created view. At this point the hang should occur.

Alternatively, open any of the attached files, all of them should hang for several seconds and longer on opening the file.

Link to the forum thread:
https://forum.freecadweb.org/viewtopic.php?f=3&t=31545
Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Croatian/Croatia (hr_HR)
TagsTechDraw

Activities

mkey

2018-10-15 16:20

reporter  

detail_sweep.FCStd (30,728 bytes)
detail_cylinder.FCStd (23,431 bytes)
detail_pipe.FCStd (24,156 bytes)

wandererfan

2018-10-17 12:44

manager   ~0012046

This should be fixed by git commit a281832627 a281832627.

wandererfan

2018-10-21 16:32

manager   ~0012078

Closed. For future reference, this was caused by OCC HLR creating many short bspline curves in the projection/HLR process. Fix was to use a cuboid cutting tool instead of a cylinder. The straight edges seem to work better than the curves.

Issue History

Date Modified Username Field Change
2018-10-15 16:20 mkey New Issue
2018-10-15 16:20 mkey Tag Attached: TechDraw
2018-10-15 16:20 mkey File Added: detail_sweep.FCStd
2018-10-15 16:20 mkey File Added: detail_cylinder.FCStd
2018-10-15 16:20 mkey File Added: detail_pipe.FCStd
2018-10-17 12:44 wandererfan Status new => resolved
2018-10-17 12:44 wandererfan Resolution open => fixed
2018-10-17 12:44 wandererfan Fixed in Version => 0.18
2018-10-17 12:44 wandererfan Target Version => 0.18
2018-10-17 12:44 wandererfan Note Added: 0012046
2018-10-21 16:32 wandererfan Assigned To => wandererfan
2018-10-21 16:32 wandererfan Status resolved => closed
2018-10-21 16:32 wandererfan Note Added: 0012078