View Issue Details

IDProjectCategoryView StatusLast Update
0003638Expressions[FreeCAD] Bugpublic2018-10-18 21:34
Reporterulrich1aAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSDebian StretchOS Version
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003638: Importing CSV-files produces an empty spreadsheet without the data
DescriptionImporting a CSV-file via the GUI or via python:
App.ActiveDocument.Spreadsheet.importFile("D:/FreeCAD/komma.csv",",")
produces an empty spreadsheet.
It did work at least in version:
OS: Debian GNU/Linux 9.5 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13983 (Git)
Build type: Release
Branch: Rueck6
Hash: 6402e62d0906d604490cfd83222ca0b100985d85
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Locale: German/Germany (de_DE)

It was reported here: https://forum.freecadweb.org/viewtopic.php?f=3&t=31532

Steps To Reproduce- Open FreeCAD and select the Spreadsheet workbench.
- Create a new document
- Import via menu/Spreadsheet/Import Spreadsheet the file given below tabulator.csv

a new spreadsheet object is created in the document, but it is empty.
Additional InformationIt fails in:
OS: Debian GNU/Linux 9.5 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14958 (Git)
Build type: Release
Branch: Rueck6
Hash: ab8431f1b1a03a8f951fa43fcdd0514c6f8c7b39
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)
Tagsspreadsheet

Activities

ulrich1a

2018-10-14 19:45

reporter  

tabulator.csv (35 bytes)

Kunda1

2018-10-15 07:08

administrator   ~0012026

Setting this to 0.18 since it's a regression

wmayer

2018-10-18 21:34

administrator   ~0012066

https://github.com/FreeCAD/FreeCAD/commit/7b866816785ac1ca9787b63d4bff12873bb3a593

Issue History

Date Modified Username Field Change
2018-10-14 19:45 ulrich1a New Issue
2018-10-14 19:45 ulrich1a Tag Attached: spreadsheet
2018-10-14 19:45 ulrich1a File Added: tabulator.csv
2018-10-15 07:08 Kunda1 Target Version => 0.18
2018-10-15 07:08 Kunda1 Note Added: 0012026
2018-10-18 21:34 wmayer Assigned To => wmayer
2018-10-18 21:34 wmayer Status new => closed
2018-10-18 21:34 wmayer Resolution open => fixed
2018-10-18 21:34 wmayer Fixed in Version => 0.18
2018-10-18 21:34 wmayer Note Added: 0012066