View Issue Details

IDProjectCategoryView StatusLast Update
0000363FreeCADBugpublic2011-05-30 12:02
ReporterunauthenticatedAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000363: Problem exporting in STEP format
DescriptionHi,
I'm importing a triangle mesh (containing faces, vertices, normals, and indices) of .obj format to freeCAD, and then I export it to STEP format. And what I got is only few information and there's no geometry information in the exported file :

ISO-10303-21;
HEADER;
FILE_DESCRIPTION(('FreeCAD Model'),'2;1');
FILE_NAME('D:/Home/EonStrife/fromFREECAD.stp','2011-05-28T10:36:02',(
    'FreeCAD'),('FreeCAD'),'Open CASCADE STEP processor 6.3','FreeCAD',
  'Unknown');
FILE_SCHEMA(('AUTOMOTIVE_DESIGN_CC2 { 1 2 10303 214 -1 1 5 4 }'));
ENDSEC;
DATA;
#1 = APPLICATION_PROTOCOL_DEFINITION('committee draft',
  'automotive_design',1997,0000002);
0000002 = APPLICATION_CONTEXT(
  'core data for automotive mechanical design processes');
0000003 = SHAPE_DEFINITION_REPRESENTATION(0000004,0000010);
0000004 = PRODUCT_DEFINITION_SHAPE('','',0000005);
0000005 = PRODUCT_DEFINITION('design','',0000006,0000009);
0000006 = PRODUCT_DEFINITION_FORMATION('','',0000007);
0000007 = PRODUCT('Open CASCADE STEP translator 6.3 1',
  'Open CASCADE STEP translator 6.3 1','',(0000008));
0000008 = MECHANICAL_CONTEXT('',0000002,'mechanical');
0000009 = PRODUCT_DEFINITION_CONTEXT('part definition',0000002,'design');
0000010 = SHAPE_REPRESENTATION('',(0000011),0000015);
0000011 = AXIS2_PLACEMENT_3D('',0000012,0000013,0000014);
0000012 = CARTESIAN_POINT('',(0.E+000,0.E+000,0.E+000));
0000013 = DIRECTION('',(0.E+000,0.E+000,1.));
0000014 = DIRECTION('',(1.,0.E+000,-0.E+000));
0000015 = ( GEOMETRIC_REPRESENTATION_CONTEXT(3)
GLOBAL_UNCERTAINTY_ASSIGNED_CONTEXT((0000019)) GLOBAL_UNIT_ASSIGNED_CONTEXT(
(0000016,0000017,0000018)) REPRESENTATION_CONTEXT('Context #1',
  '3D Context with UNIT and UNCERTAINTY') );
0000016 = ( LENGTH_UNIT() NAMED_UNIT(*) SI_UNIT(.MILLI.,.METRE.) );
0000017 = ( NAMED_UNIT(*) PLANE_ANGLE_UNIT() SI_UNIT($,.RADIAN.) );
0000018 = ( NAMED_UNIT(*) SI_UNIT($,.STERADIAN.) SOLID_ANGLE_UNIT() );
0000019 = UNCERTAINTY_MEASURE_WITH_UNIT(LENGTH_MEASURE(1.E-007),0000016,
  'distance_accuracy_value','confusion accuracy');
0000020 = PRODUCT_TYPE('part',$,(0000007));
ENDSEC;
END-ISO-10303-21;
TagsNo tags attached.

Activities

unauthenticated

2011-05-28 04:32

viewer   ~0000865

Correction : not a triangle mesh, but a quad mesh

yorik

2011-05-28 21:18

administrator   ~0000866

That is because, I think, meshes are not taken into account by the Part module (responsible for exporting to brep, step and iges). I'm not sure how practical/easy it would be to export meshes to step format...

unauthenticated

2011-05-30 00:02

viewer   ~0000872

yeah..need to check the STEP documentation. So far, can't find any tools that can convert mesh to STEP..I wonder if it's impossible..

yorik

2011-05-30 11:35

administrator   ~0000873

One solution is to convert your meshes to Part shapes (via the Part->Make Part from Mesh command). Then they will be exported to STEP. But Converting meshes to parts can be a rather heavy operation that will only be interesting if your meshes are quite simple, otherwise the part objects will be almost unmanageable.

wmayer

2011-05-30 11:48

administrator   ~0000874

To make a BREP of a mesh object follow the way Yorik suggested. Afterwards you can export this object to STEP.

I guess what you did is loading the quad mesh, selected it and tried to export this to STEP. However, the export function inside only checks for special objects and ignores all the others. I think it's better to print at least a message when an object is ignored.

wmayer

2011-05-30 12:02

administrator   ~0000875

Fixed in r4532. A message is printed when ignoring objects from being exported to STEP, IGES or BREP.

Issue History

Date Modified Username Field Change
2011-05-28 01:20 unauthenticated New Issue
2011-05-28 04:32 unauthenticated Note Added: 0000865
2011-05-28 21:18 yorik Note Added: 0000866
2011-05-30 00:02 unauthenticated Note Added: 0000872
2011-05-30 11:35 yorik Note Added: 0000873
2011-05-30 11:48 wmayer Note Added: 0000874
2011-05-30 12:02 wmayer Note Added: 0000875
2011-05-30 12:02 wmayer Status new => closed
2011-05-30 12:02 wmayer Resolution open => fixed
2011-05-30 12:02 wmayer Fixed in Version => 0.12