View Issue Details

IDProjectCategoryView StatusLast Update
0003605FreeCADBugpublic2019-02-21 12:32
ReporterDavid_DAssigned Towmayer 
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformOSSolusOS Version
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003605: Scrolling on length inputs with "Building Euro" unit system has max value
Description When using my mouse scroll wheel to increase or decrease GUI input boxes for length values, the maximum value that can be reached is 0.11cm, and the minimum is -0.11cm. Here is a video demonstrating the issue: https://gfycat.com/DemandingAdorableKudu

After some testing, I discovered this issue only occurs:

* When the Building Euro units user system is selected. (Preferences>General>Units>User system) Expected behavior occurs with all other unit systems, eg: Metric small parts.
* With length values. Degrees input boxes work as expected.
* Within task panels. Editing the data within a property or hybrid view panel directly has the expected behavior.

There was only one error with the TestApp.All test.

The forum discussion: https://forum.freecadweb.org/viewtopic.php?f=3&t=30991&p=257340
Steps To Reproduce
  1. Open a FreeCAD file.
  2. Change your units system to Building Euro (Preferences>General>Units>User system)
  3. Select a tool that opens the task window, such as Draft Line, Arch Wall, etc.
  4. Place your mouse over one of the input boxes that contain a length value, such as Global X, Global Y, or Length.
  5. Scroll up or down, to increase or decrease the value.
  6. Note that it will not increase beyond 0.11cm, or decrease below -0.11cm.
Additional InformationTested with both 0.17 and 0.18:


OS: "Solus"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/NewZealand (en_NZ)

 OS: "Solus"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14766 (Git) AppImage
Build type: Release
Branch: master
Hash: 17d36cecc992cfa9c9a4a831f23a6e4dcd6cc41e
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/NewZealand (en_NZ)

 OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14727 (Git)
Build type: Release
Branch: master
Hash: c6df59969bfb3ae2027e2b47ddd559852f6e9a4e
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
Tagsunits

Activities

David_D

2018-09-19 16:50

developer  

ranch_plan.fcstd (85,324 bytes)

Kunda1

2018-10-02 21:31

administrator   ~0011897

wmayer, I assigned this to you. Hope that's OK.

wmayer

2019-02-21 07:05

administrator   ~0012710

This is not a bug in the "Building Euro" unit system. It is a bug in InputField which only occurs in combination with the above unit system.

The reason for this misbehaviour is an inconsistent interpretation of the numbers:
When the input field shows the number 0.11 cm and you scroll then the number becomes 1.11 but when passing it to the unit system translator the number wasn't calculated in mm beforehand. Because internally all lengths are in mm (independent of any user settings) the unit system translator correctly assumes the value in mm and when translating it into cm it becomes 0.111 and because of a precision of two again becomes 0.11.

wmayer

2019-02-21 12:32

administrator   ~0012711

https://github.com/FreeCAD/FreeCAD/commit/66da83ef92b7ea6d0656eb66c5a9c6b4e57efaa0

Issue History

Date Modified Username Field Change
2018-09-19 16:50 David_D New Issue
2018-09-19 16:50 David_D Tag Attached: units
2018-09-19 16:50 David_D File Added: ranch_plan.fcstd
2018-10-02 21:28 Kunda1 Status new => confirmed
2018-10-02 21:30 Kunda1 Assigned To => wmayer
2018-10-02 21:30 Kunda1 Status confirmed => assigned
2018-10-02 21:31 Kunda1 Note Added: 0011897
2018-10-02 21:32 Kunda1 Description Updated View Revisions
2018-10-02 21:32 Kunda1 Description Updated View Revisions
2019-02-21 07:05 wmayer Note Added: 0012710
2019-02-21 12:32 wmayer Status assigned => closed
2019-02-21 12:32 wmayer Resolution open => fixed
2019-02-21 12:32 wmayer Fixed in Version => 0.18
2019-02-21 12:32 wmayer Note Added: 0012711