View Issue Details

IDProjectCategoryView StatusLast Update
0000359FreeCADBugpublic2011-10-25 13:14
ReporterwmayerAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version 
Target Version0.12Fixed in Version 
Summary0000359: STEP import doesn't always work if two or more objects are included.
DescriptionFor more details see: https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=12&t=1020&p=7820#p7820
Additional InformationUsing CAD Exchanger the STEP loads fine but the IGES is also broken.
TagsNo tags attached.

Activities

2011-05-26 06:02

 

objet_sphere.zip (Attachment missing)

wmayer

2011-05-30 12:22

administrator   ~0000876

The STEP import works but it seems the tessellation for displaying of the second object doesn't work.

Jriegel

2011-05-31 14:42

administrator   ~0000877

QuickStep shows also only one Part. This is a CAD viewer based on OCC.
So seams not our fault ;)

unauthenticated

2011-05-31 19:58

viewer   ~0000878

> QuickStep shows also only one Part. This is a CAD viewer based on OCC.
> So seams not our fault ;)
That's not fully true. It mainly depends on how to handle the read-in STEP model afterwards. Many applications simply use only the first object and ignore further ones. And CAD Exchanger IS able to load both objects.

But the problem is not the STEP loading, it's the visualization of the second object. This object is a sphere but it's represented by a B-Spline surface and for any reason the tessellation algorithm fails to create a valid mesh from it.

On the other hand the SMESH module is able to create a mesh from it.

Jriegel

2011-08-25 07:39

administrator   ~0001000

There was some discussions on the OCE list about the quality of the
OCC view mesher. But thats something we have to tackle as a patch
for OCC :(

I dont think we can do anything on our side...

wmayer

2011-09-07 07:41

administrator   ~0001051

Here a little script to reproduce this OCC bug:

s=Part.makeSphere(10)
Part.show(s)
b=s.toNurbs()
Part.show(b)

Jriegel

2011-10-25 07:47

administrator   ~0001191

Not fixable so far on our side. Wait on better tessellation with OCE or OCC.

Issue History

Date Modified Username Field Change
2011-05-26 06:02 wmayer New Issue
2011-05-26 06:02 wmayer Status new => assigned
2011-05-26 06:02 wmayer Assigned To => wmayer
2011-05-26 06:02 wmayer File Added: objet_sphere.zip
2011-05-30 12:22 wmayer Note Added: 0000876
2011-05-31 14:42 Jriegel Note Added: 0000877
2011-05-31 19:58 unauthenticated Note Added: 0000878
2011-08-25 07:39 Jriegel Note Added: 0001000
2011-09-07 07:41 wmayer Note Added: 0001051
2011-10-25 07:47 Jriegel Note Added: 0001191
2011-10-25 07:47 Jriegel Status assigned => resolved
2011-10-25 07:47 Jriegel Resolution open => not fixable
2011-10-25 13:14 wmayer Status resolved => closed