View Issue Details

IDProjectCategoryView StatusLast Update
0003563Path[FreeCAD] Bugpublic2018-09-01 19:03
Reportersliptonic Assigned Tomlampert  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003563: Stock object placement not correctly updated when origin set.
Descriptionhttps://www.youtube.com/watch?v=g36iWSviaMY&feature=youtu.be

The Base-Body object placement changes correctly but the stock object does not.
TagsNo tags attached.
FreeCAD Information

Activities

mlampert

2018-08-21 18:55

developer   ~0011634

Interesting - looks like the position change is applied to Stock twice.

mlampert

2018-08-22 22:18

developer   ~0011636

The behaviour is specific to the stock from base model's extent because that one was expected to track the placement of the base model automatically - resulting in the shift being applied twice.

It is more consistent to not track the base object's placement after creation.

wmayer

2018-09-01 19:03

administrator   ~0011678

https://github.com/FreeCAD/FreeCAD/commit/5b39974bfb6964ae129f0fc66df9464fa1c6178a

Issue History

Date Modified Username Field Change
2018-08-21 16:45 sliptonic New Issue
2018-08-21 16:45 sliptonic Status new => assigned
2018-08-21 16:45 sliptonic Assigned To => mlampert
2018-08-21 18:55 mlampert Note Added: 0011634
2018-08-22 22:18 mlampert Note Added: 0011636
2018-09-01 19:03 wmayer Status assigned => closed
2018-09-01 19:03 wmayer Resolution open => fixed
2018-09-01 19:03 wmayer Fixed in Version => 0.18
2018-09-01 19:03 wmayer Note Added: 0011678