View Issue Details

IDProjectCategoryView StatusLast Update
0003558ArchBugpublic2018-11-01 17:44
ReporterWilsonAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows 7, Windows 10OS Version64-bit
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003558: Arch Windows - Problem with Draft to Sketch
DescriptionI'm halfway through the Arch Tutorial and I'm having issues, creating the curtain walls. I did a small part of it as explained in the tutorial and it was fine, using several rectangles and then converting these draft objects to a sketch with the Draft To Sketch tool. Now I'm trying to do the same with a bigger section of the curtain wall and I can't. The sketch seems to be empty every time I repeat this process. To model these objects I'm using the dxf reference, as in the tutorial.

I tried to repeat the process with another computer and some draft objects, after applying the draft2sketch tool, are converted to sketch with no problems, but with others, the result is the same as before, a new sketch completely empty. I tried this with both the latest stable version (0.17.13528) as well with the 0.18 development version. The result is the same, some draft objects are converted to sketch with no problem, others aren't. Also, it seems to be random, I can't find a pattern to in order to understand why some objects work fine and others don't. I believe it's a bug.

Link to the discussion in the forum
Steps To Reproduce1. Open FreeCAD
2. Press the "open document" button and open "Artigas v2.3"
3. Switch to the Arch workbench
4. Press the "Create Draft Wire" button and draw wires on top of the reference drawing (the plan elevation), already imported in the file. These wires are meant to reproduce the shape of the windows
5. Select all created wires and press "Draft to Sketch" button
6. All draft objects are converted to sketch, but when opening, most of them are "empty sketches"
7. Impossible to convert sketch to window correctly, since most sketches are empty
TagsArch, Draft, Sketch

Activities

Wilson

2018-08-14 12:00

reporter  

Artigas v2.3.FCStd (542,678 bytes)
printscreen.jpg (451,847 bytes)
printscreen.jpg (451,847 bytes)

Kunda1

2018-08-14 12:06

administrator   ~0011619

@wilson thanks for the report. Please follow our guidelines next time about opening tickets. We prefer that folks post issues to the forum first. (See enormous yellow banner at the top of this page).

@yorik care to weigh in ?

Wilson

2018-08-14 12:18

reporter   ~0011621

@Kunda1 sorry, I thought I did it. On the forum, at the "Help on using FreeCAD" board, I made a post describing this situation, 2 days ago. I didn't want to open a ticket here right away, but since then I've been trying to solve the situation with no success. It seemed more and more like a bug so I decided to report. Sorry if I did it the wrong way. In which forum topic/board should I make the post next time? I looked for a bug topic but couldn't find.

Wilson

2018-08-14 18:16

reporter   ~0011624

Last edited: 2018-10-02 21:04

View 2 revisions

I tried again with another computer and this is what I get in the Report View after selecting all the wires and applying the Draft2Sketch.

('[Draft.todo.commit] Unexpected error:', <class 'Base.FreeCADError'>, 'in ', <built-in 
method closeDialog of tuple object at 0x0000021F1EC54188>, '(', None, ')')


yorik

2018-10-03 19:50

administrator   ~0011904

I cannot reproduce the problem here... Everything seems to work normally.
Can you try to upload a file containing a draft wire that doesn"t get converted to a sketch?

Kunda1

2018-10-03 19:53

administrator   ~0011905

Last edited: 2018-10-03 19:53

View 2 revisions

@yorik thanks for getting to this. Quick favor (for organization), when you respond to tickets that require answers from their OPs, do you mind setting the status to 'Feedback'? The ticket will still stay assigned to you but the status will be pending on the OP. Then we can easily go back and see what tickets are pending responses. Thanks! (I took care of it for this one already ;) )

Edit: Also once OP responds the Status goes back to Blue ('Assigned')

Kunda1

2018-10-17 20:40

administrator   ~0012058

@Wilson please respond

Wilson

2018-10-18 14:47

reporter   ~0012065

Last edited: 2018-10-18 14:48

View 3 revisions

@yorik sorry for replying just now. I send the file attached to this conversation. Like I said on the forum, it seems that the draft2sketch tool doesn't work properly if the drawings are something else than rectangles. With simple shapes it seems to work fine, as well as with one or two polygons with irregular angles. The problem happens you have a more complex shape, say a curtain wall, like in the Arch Tutorial, with several different angles in its wires/polygons. Link to the discussion here



Artigas v2.3-2.FCStd (558,397 bytes)

yorik

2018-11-01 17:44

administrator   ~0012125

Fixed with https://git.io/fxAuT

Issue History

Date Modified Username Field Change
2018-08-14 12:00 Wilson New Issue
2018-08-14 12:00 Wilson Tag Attached: Arch
2018-08-14 12:00 Wilson Tag Attached: Draft
2018-08-14 12:00 Wilson Tag Attached: Sketch
2018-08-14 12:00 Wilson File Added: Artigas v2.3.FCStd
2018-08-14 12:00 Wilson File Added: printscreen.jpg
2018-08-14 12:06 Kunda1 Note Added: 0011619
2018-08-14 12:18 Wilson Note Added: 0011621
2018-08-14 18:16 Wilson Note Added: 0011624
2018-10-02 21:04 Kunda1 Description Updated View Revisions
2018-10-02 21:04 Kunda1 Note Edited: 0011624 View Revisions
2018-10-02 21:05 Kunda1 Assigned To => yorik
2018-10-02 21:05 Kunda1 Status new => assigned
2018-10-02 21:05 Kunda1 Severity major => minor
2018-10-03 19:50 yorik Note Added: 0011904
2018-10-03 19:53 Kunda1 Status assigned => feedback
2018-10-03 19:53 Kunda1 Note Added: 0011905
2018-10-03 19:53 Kunda1 Note Edited: 0011905 View Revisions
2018-10-17 20:40 Kunda1 Note Added: 0012058
2018-10-18 14:47 Wilson File Added: Artigas v2.3-2.FCStd
2018-10-18 14:47 Wilson Note Added: 0012065
2018-10-18 14:47 Wilson Status feedback => assigned
2018-10-18 14:48 Wilson Note Edited: 0012065 View Revisions
2018-10-18 14:48 Wilson Note Edited: 0012065 View Revisions
2018-10-19 13:17 Kunda1 Target Version => 0.18
2018-11-01 17:44 yorik Status assigned => closed
2018-11-01 17:44 yorik Resolution open => fixed
2018-11-01 17:44 yorik Fixed in Version => 0.18
2018-11-01 17:44 yorik Note Added: 0012125