View Issue Details

IDProjectCategoryView StatusLast Update
0003522FreeCADBugpublic2019-01-18 10:49
ReportermaxvAssigned Tochrisb 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
PlatformOSLinux, WindowsOS Version
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003522: Save Image creates incorrect result with transparency
DescriptionHello,
if you use tools -> Save Image... using a model with transparencies, you get the wrong result. All transparent objects are places over the rest objects, even if the are behind, so the resulting image is wrong.
I attached an example of a transparent box with an object inside. The wall of the box a placed wrong.
TagsQt5, transparency

Relationships

child of 0002986 confirmed Port from Qt4 to Qt5 (Ongoing) 

Activities

maxv

2018-06-28 22:13

reporter  

bug.png (47,379 bytes)
bug.png (47,379 bytes)
correct.png (180,453 bytes)
correct.png (180,453 bytes)

Kunda1

2018-07-03 02:09

administrator   ~0011480

@maxv the large yellow banner is there for a reason. Please follow the instructions on how FC community prefers how users post bugs.

Kunda1

2018-07-12 12:31

administrator   ~0011519

@maxv please add your version info (Help > About FreeCAD > Copy to clipboard) and upload an example file, even better do this in the forum and link the thread back to this ticket and link from this ticket to the thread.

maxv

2018-07-18 22:31

reporter   ~0011536

OS: Linux Mint 17 Qiana
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.Unknown
Build type: Unknown
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0

plexiglass2_chiuso.fcstd (105,699 bytes)

Kunda1

2018-07-27 14:03

administrator   ~0011549

@normandc please weigh in on this ticket..thanks

normandc

2018-07-29 15:58

manager   ~0011562

maxv's FC info is incomplete with revision number unknown. Obviously he didn't install FreeCAD from one of the two preferred methods for Ubuntu & derivatives.

This has been already discussed in the forum. The report author should have searched the forum first. I won't search for topics myself I have better things to do.

maxv

2018-07-30 12:42

reporter   ~0011566

I installed the appimage.
The same bug with version:

OS: Linux Mint 17.2 Rafaela
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13522 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 3bb5ff4e70c0c526f2d9dd69b1004155b2f527f2
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Italian/Italy (it_IT)

Kunda1

2018-08-23 17:09

administrator   ~0011644

@chrisb can you weigh in? Not finding where this subject was discussed in the forums.

wmayer

2018-10-04 08:04

administrator   ~0011912

I can't reproduce it with:
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14888 (Git)
Build type: Release
Branch: master
Hash: 93f06f82560820469b63939b35557bea4dffa2e9
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: German/Germany (de_DE)

But the problem could be related to the OpenGL driver or Qt4 which is known to cause problems here and there on modern Linux systems. If there is a chance then it would be good to use a build that uses Qt5.

Kunda1

2018-10-05 23:52

administrator   ~0011935

@maxv can you try reproducing this issue on the Qt5 appimage for 0.18dev (https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre)

maxv

2018-10-15 20:13

reporter   ~0012034

Bug still present in 0.18

test.jpg (35,951 bytes)
test.jpg (35,951 bytes)

maiden

2019-01-16 15:19

reporter   ~0012442

Last edited: 2019-01-16 21:33

View 3 revisions

I confirm this issue on:

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.
Build type: None
Python version: 2.7.15
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.9.1.oce-0.18

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

this might be helpful: http://developer.download.nvidia.com/assets/gamedev/docs/PixelBuffers.pdf


with 0.18 i get the following issue
https://forum.freecadweb.org/viewtopic.php?f=3&t=13044&p=280601#p280601

maiden

2019-01-16 15:24

reporter   ~0012443

bottom view, GUI vs rendered image on 0.17 appimg

maiden

2019-01-18 10:08

reporter  

maiden

2019-01-18 10:08

reporter   ~0012455

hmm, today it works fine with 0.17 appimg

OS: Ubuntu 18.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)

maiden

2019-01-18 10:09

reporter   ~0012456

this is starting to smell graphics driver issue...

chrisb

2019-01-18 10:49

developer   ~0012457

Closed as graphics driver issue.

Issue History

Date Modified Username Field Change
2018-06-28 22:13 maxv New Issue
2018-06-28 22:13 maxv File Added: bug.png
2018-06-28 22:13 maxv File Added: correct.png
2018-07-03 02:09 Kunda1 Status new => feedback
2018-07-03 02:09 Kunda1 Note Added: 0011480
2018-07-03 02:09 Kunda1 Priority high => normal
2018-07-03 02:09 Kunda1 Severity major => minor
2018-07-12 12:31 Kunda1 Note Added: 0011519
2018-07-18 22:31 maxv File Added: plexiglass2_chiuso.fcstd
2018-07-18 22:31 maxv Note Added: 0011536
2018-07-18 22:31 maxv Status feedback => new
2018-07-27 14:03 Kunda1 Note Added: 0011549
2018-07-29 15:58 normandc Note Added: 0011562
2018-07-30 12:42 maxv Note Added: 0011566
2018-08-23 17:09 Kunda1 Note Added: 0011644
2018-10-04 08:04 wmayer Note Added: 0011912
2018-10-05 23:50 Kunda1 Tag Attached: transparency
2018-10-05 23:52 Kunda1 Status new => feedback
2018-10-05 23:52 Kunda1 Note Added: 0011935
2018-10-05 23:54 Kunda1 Tag Attached: Qt5
2018-10-05 23:54 Kunda1 Relationship added child of 0002986
2018-10-15 20:13 maxv File Added: test.jpg
2018-10-15 20:13 maxv Note Added: 0012034
2018-10-15 20:13 maxv Status feedback => new
2018-10-15 20:56 Kunda1 Target Version => 0.18
2019-01-16 15:19 maiden Note Added: 0012442
2019-01-16 15:24 maiden File Added: Screenshot from 2019-01-16 16-22-42.png
2019-01-16 15:24 maiden File Added: Screenshot from 2019-01-16 16-22-52.png
2019-01-16 15:24 maiden Note Added: 0012443
2019-01-16 15:38 maiden Note Edited: 0012442 View Revisions
2019-01-16 21:33 maiden Note Edited: 0012442 View Revisions
2019-01-18 10:08 maiden File Added: Screenshot from 2019-01-18 11-06-31.png
2019-01-18 10:08 maiden File Added: Screenshot from 2019-01-16 16-22-42-2.png
2019-01-18 10:08 maiden Note Added: 0012455
2019-01-18 10:09 maiden Note Added: 0012456
2019-01-18 10:49 chrisb Assigned To => chrisb
2019-01-18 10:49 chrisb Status new => closed
2019-01-18 10:49 chrisb Resolution open => not fixable
2019-01-18 10:49 chrisb Fixed in Version => 0.18
2019-01-18 10:49 chrisb Note Added: 0012457