View Issue Details

IDProjectCategoryView StatusLast Update
0003519Part[FreeCAD] Bugpublic2018-09-13 11:33
ReporterDeepSOIC Assigned ToDeepSOIC  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0003519: Attachment Flip Sides faulty behavior on O-ax-ax modes
DescriptionTicking Flip Sides checkbox when attached with O-X-Y mode for example creates weird angles.
Steps To Reproduce1. Add Part Box.
2. Add Part Cylinder
3. Attach Cylinder to box using any O-axis-axis mode.
4. tick Flip Sides -> cylinder rotates into a weird angle.
Additional Informationapparently caused by wrong angle (specified in degrees rather than radians). Seems trivial to fix.
Tagsattachment
FreeCAD Information

Issue History

Date Modified Username Field Change
2018-06-22 22:49 DeepSOIC New Issue
2018-06-22 22:49 DeepSOIC Status new => assigned
2018-06-22 22:49 DeepSOIC Assigned To => DeepSOIC
2018-06-22 22:49 DeepSOIC Tag Attached: attachment
2018-09-13 11:33 wmayer Status assigned => closed
2018-09-13 11:33 wmayer Resolution open => fixed
2018-09-13 11:33 wmayer Fixed in Version => 0.18
2018-09-13 11:33 wmayer Note Added: 0011724