View Issue Details

IDProjectCategoryView StatusLast Update
0003513FreeCADBugpublic2018-09-25 11:23
Reporteromni_brainAssigned Towmayer 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003513: Can't open file - some exceptions are shown in the log
DescriptionI'm new to cad and played a bit around with FreeCAD - may've made some mistakes with mesh constraints - however I would expect that the program maybe becomes slow but not destroying files :)

I've attached the file - it always gives:
-----------
Traceback (most recent call last):
  File "C:\Program Files\FreeCAD 0.17\bin\lib\json\__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "C:\Program Files\FreeCAD 0.17\bin\lib\json\decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "C:\Program Files\FreeCAD 0.17\bin\lib\json\decoder.py", line 382, in raw_decode
    raise ValueError("No JSON object could be decoded")
<type 'exceptions.ValueError'>: No JSON object could be decoded
------------

Note that I used 0.18 designing that - I switched back to 0.17. I hope it helps.
Steps To ReproduceTry to load the file in 0.17 or 0.18 - loads somewhat but shows an error in the log
TagsNo tags attached.

Activities

omni_brain

2018-06-16 16:20

reporter  

k2.FCStd (122,635 bytes)

Kunda1

2018-06-17 11:01

administrator   ~0011446

@omni_brain
omni_brain wrote

Note that I used 0.18 designing that - I switched back to 0.17

This should be your first red flag. Try to start from scratch in 0.17 and recreate the steps and see if you get an issue. Some feedback about your ticket, you are missing key info to help us help you. Please read the enormous yellow banner at the top of the tracker page on how FreeCAD asks the community to go about reporting tickets

omni_brain

2018-06-17 13:45

reporter   ~0011448

I switched back to 0.17 because I couldn't load the file & edit the mesh with 0.18. I didn't use 0.17 and 0.18 to create that. Nor did I save that file with 0.17. It was just additional info what I've tried.

I hoped that 0.17 could save some of my work - but it just showed the traceback from above.
IDK when I've time to redo that - I think I'll first learn more about CAD software, maybe I made a bit too many constraints there. But in any case a good software product shouldn't produce invalid files/cause loss of work.

The file can be opened and the 3d object can be seen but one of the meshes can't be edited :/.

But that teaches me that if I use freecad I should do vsc for the cad files :).

wmayer

2018-09-25 11:23

administrator   ~0011833

https://github.com/FreeCAD/FreeCAD/commit/b112ac0ec1ace8c297e6a2affc511a8e517a3fa5

The error message is a false-positive and the file can be loaded without any loss of information.

Issue History

Date Modified Username Field Change
2018-06-16 16:20 omni_brain New Issue
2018-06-16 16:20 omni_brain File Added: k2.FCStd
2018-06-17 11:01 Kunda1 Status new => feedback
2018-06-17 11:01 Kunda1 Note Added: 0011446
2018-06-17 13:45 omni_brain Note Added: 0011448
2018-06-17 13:45 omni_brain Status feedback => new
2018-09-25 11:23 wmayer Assigned To => wmayer
2018-09-25 11:23 wmayer Status new => closed
2018-09-25 11:23 wmayer Resolution open => fixed
2018-09-25 11:23 wmayer Fixed in Version => 0.18
2018-09-25 11:23 wmayer Note Added: 0011833