View Issue Details

IDProjectCategoryView StatusLast Update
0003503SketcherBugpublic2018-06-09 09:16
ReporterabdullahAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.18Fixed in Version0.18 
Summary0003503: Failure to update solver information on addition of constraint
DescriptionSometimes on addition of a constraint, the solver information is not accurate.
Steps To Reproduce1. Load the attached sketch
2. Delete the symmetry constraint
3. Rotate one endpoint of the arc so that it is not in the position of symmetry
4. Reapply the symmetry constraint.

The result is a fully constraint sketch, which is false. Just drag one endpoint of the arc and it will move.
Additional Information
The example is just one example where the problem is very apparent as it shows "fully constraint". It also happens in other situations where simply the DoFs reported are wrong.
TagsNo tags attached.

Activities

abdullah

2018-06-08 21:45

manager  

arc_sym.fcstd (3,334 bytes)

abdullah

2018-06-08 21:51

manager  

abdullah

2018-06-08 21:52

manager   ~0011369

https://github.com/FreeCAD/FreeCAD/pull/1502

abdullah

2018-06-08 21:53

manager   ~0011370

@triplus

Finally this one is fixed. It was not a solver problem after all, just a failure to update the solver information.

wmayer

2018-06-09 09:16

administrator   ~0011380

https://github.com/FreeCAD/FreeCAD/commit/d6d26b6a8983b7a0678d268ab98e218d34995f26

Issue History

Date Modified Username Field Change
2018-06-08 21:45 abdullah New Issue
2018-06-08 21:45 abdullah Status new => assigned
2018-06-08 21:45 abdullah Assigned To => abdullah
2018-06-08 21:45 abdullah File Added: arc_sym.fcstd
2018-06-08 21:51 abdullah File Added: wrong_fully_constraint1.png
2018-06-08 21:52 abdullah Note Added: 0011369
2018-06-08 21:53 abdullah Note Added: 0011370
2018-06-09 09:16 wmayer Status assigned => closed
2018-06-09 09:16 wmayer Resolution open => fixed
2018-06-09 09:16 wmayer Fixed in Version => 0.18
2018-06-09 09:16 wmayer Note Added: 0011380