View Issue Details

IDProjectCategoryView StatusLast Update
0003502Path[FreeCAD] Bugpublic2018-06-09 09:17
ReportermlampertAssigned Tomlampert 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003502: Engraving produces wrong path
DescriptionEngraving text with the `osifont_lgpl3.ttf` font (shipped with FC in the TechDraw module) produces a (seriously) wrong path.
The wrongness of the path seems to depend on the absolute position of the shapestring, it is different after moving the string to the origin.

Discussion:

https://forum.freecadweb.org/viewtopic.php?f=15&t=29177
TagsNo tags attached.

Activities

mlampert

2018-06-09 07:22

developer   ~0011375

The root cause was the tolerance setting for converting bezier curves and splines (0.5). In switching that I noticed that the same checks had already been implemented in PathGeom. So I changed the implementation to use that.

https://github.com/FreeCAD/FreeCAD/pull/1503/commits/79db94cee2c09e5c5020971d036330434470572e

wmayer

2018-06-09 09:17

administrator   ~0011381

https://github.com/FreeCAD/FreeCAD/commit/f0e6b696905d77aeef72c7bb64f94db4b1a2f1fb

Issue History

Date Modified Username Field Change
2018-06-08 19:06 mlampert New Issue
2018-06-08 20:19 mlampert Summary Path rendering introduces wrong artifacts => Engraving produces wrong path
2018-06-08 20:19 mlampert Description Updated View Revisions
2018-06-09 00:07 mlampert Assigned To => mlampert
2018-06-09 00:07 mlampert Status new => assigned
2018-06-09 07:22 mlampert Note Added: 0011375
2018-06-09 07:23 mlampert Target Version => 0.18
2018-06-09 09:17 wmayer Status assigned => closed
2018-06-09 09:17 wmayer Resolution open => fixed
2018-06-09 09:17 wmayer Fixed in Version => 0.18
2018-06-09 09:17 wmayer Note Added: 0011381