View Issue Details

IDProjectCategoryView StatusLast Update
0003485DraftBugpublic2019-02-19 22:57
Reporterroland Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacintoshOSos XOS Version10.13.4
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003485: Draft : The move tool does not work correctly
DescriptionIn the draft mode, when I click a corner in order to drag it to another corner, the part i'm dragging is not moved (at all) or is moved in a totally different way. (see picture enclosed)
Steps To Reproduce- Click any corner of the enclose FCStd file (in pink color on the png file and try to drag it using the move tool.
- A "ghost" part is drawn but NOT a the right position (in my case, lower) and it's impossible to drop the part anywhere.
Additional InformationI've tried with two distinct mice (the regular one with a ball on top, and a "magic mouse" wireless) : same result.

I've tried with a previous version of "os X" (el capitain) and it seems to work fine (i'm not very familiar with the move tool, but the moves are ot eratic as they are on os X 10.13.4.)

Version :

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13519 (Git)
Build type: Release
Branch: (HEAD detached at 1a8b868)
Hash: 1a8b868018f45ea486c0023fdbfeb06febc1fb89
Python version: 2.7.14
Qt version: 5.10.1
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)

Thanks for your work !

Roland Lannuzel
(Paris, France)
Tagsmouse, mouse-gestures
FreeCAD Information

Activities

roland

2018-05-18 08:22

reporter  

Draft.png (396,474 bytes)
Draft.png (396,474 bytes)
Clones.FCStd (66,025 bytes)

roland

2018-05-18 08:42

reporter   ~0011258

Please, read DRAFT MODE instead of SKETCH MODE :-/
(don't know if i could have edited my report)

Kunda1

2018-05-29 19:49

administrator   ~0011300

@roland please post this issue for community discussion on the forums. Reference this ticket and also reference the forum link in this ticket.

Kunda1

2018-06-11 00:50

administrator   ~0011402

@chrisb care to weigh in ?

Kunda1

2018-07-05 02:15

administrator   ~0011496

@chrisb ping

Kunda1

2018-07-12 12:04

administrator   ~0011516

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=29731

chrisb

2018-07-12 15:40

developer   ~0011522

Sorry for being late. I can reproduce the issue here:

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13976 (Git)
Build type: Release
Branch: (HEAD detached at fae0de5)
Hash: fae0de58581694157a97d567c151bdce75d387dc
Python version: 2.7.15
Qt version: 5.11.0
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)

Kunda1

2018-07-12 18:33

administrator   ~0011524

Changed from Sketcher to Draft
Confirmed by DeepSOIC in https://forum.freecadweb.org/viewtopic.php?f=8&t=29731&p=244126#p244111

jzroth

2019-02-07 04:15

reporter   ~0012588

Just reproduced this on 0.18.15780 on Linux 64-bit. This bug is making it difficult for me to work with large multi-part projects containing a mixture of Part and PartDesign objects.

yorik

2019-02-16 22:45

administrator   ~0012670

The problem is only cosmetic. The "ghost" (the temporary shape displayed while using Draft Move) is not taking the Part displacement into consideration. But since it is a direct copy of the base object's coin node, it should appear at the same place.. I need to investigate more how the Part container works.

In any case, the actual moving of object works correctly (for the ones that are permitted to move, of course, as there are several pads there)

yorik

2019-02-19 22:57

administrator   ~0012697

Fixed with https://github.com/FreeCAD/FreeCAD/compare/3fc17edb4149...187988b64b7d

Issue History

Date Modified Username Field Change
2018-05-18 08:22 roland New Issue
2018-05-18 08:22 roland Tag Attached: Draft
2018-05-18 08:22 roland Tag Attached: mouse
2018-05-18 08:22 roland Tag Attached: mouse-gestures
2018-05-18 08:22 roland File Added: Draft.png
2018-05-18 08:22 roland File Added: Clones.FCStd
2018-05-18 08:42 roland Note Added: 0011258
2018-05-29 19:48 Kunda1 Summary Sketch mode : The move tool does not work correctly (high sierra only?) => Draft mode : The move tool does not work correctly (high sierra only?)
2018-05-29 19:48 Kunda1 Additional Information Updated View Revisions
2018-05-29 19:49 Kunda1 Assigned To => Kunda1
2018-05-29 19:49 Kunda1 Status new => feedback
2018-05-29 19:49 Kunda1 Note Added: 0011300
2018-06-11 00:49 Kunda1 Summary Draft mode : The move tool does not work correctly (high sierra only?) => Sketcher : The move tool does not work correctly (high sierra only?)
2018-06-11 00:49 Kunda1 Project Draft => Sketcher
2018-06-11 00:49 Kunda1 Tag Detached: Draft
2018-06-11 00:50 Kunda1 Note Added: 0011402
2018-07-05 02:15 Kunda1 Note Added: 0011496
2018-07-12 12:04 Kunda1 Note Added: 0011516
2018-07-12 15:40 chrisb Note Added: 0011522
2018-07-12 18:31 Kunda1 Summary Sketcher : The move tool does not work correctly (high sierra only?) => Draft : The move tool does not work correctly (high sierra only?)
2018-07-12 18:31 Kunda1 Description Updated View Revisions
2018-07-12 18:31 Kunda1 Project Sketcher => Draft
2018-07-12 18:33 Kunda1 Assigned To Kunda1 =>
2018-07-12 18:33 Kunda1 Status feedback => confirmed
2018-07-12 18:33 Kunda1 Note Added: 0011524
2018-07-12 18:33 Kunda1 Target Version => 0.18
2018-08-26 00:06 Kunda1 Summary Draft : The move tool does not work correctly (high sierra only?) => Draft : The move tool does not work correctly
2019-02-07 04:15 jzroth Note Added: 0012588
2019-02-16 22:45 yorik Note Added: 0012670
2019-02-16 22:46 yorik Assigned To => yorik
2019-02-16 22:46 yorik Status confirmed => assigned
2019-02-19 22:57 yorik Note Added: 0012697
2019-02-19 22:57 yorik Status assigned => closed
2019-02-19 22:57 yorik Resolution open => fixed
2019-02-19 22:57 yorik Fixed in Version => 0.18