View Issue Details

IDProjectCategoryView StatusLast Update
0003484DraftBugpublic2018-09-22 19:18
Reportersteelman Assigned Tonormandc  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.16 
Target Version0.18Fixed in Version 
Summary0003484: Open paths are closed upon upgrade
DescriptionOpen paths imported from SVG files are closed with an additional straight edge upon upgrade in the Draft workbench.
Steps To Reproduce1. Create an SVG file with a single path comprising three nodes (see also bug 0003483).
2. Import the file into the Draft workbench as geometry.
3. Select the path and use the upgrade tool.

Expected result:

The path is converted to a Wire (or a Block, or other object that can be displayed in the Drawing workbench) as it is.

Actual result:

The path is converted to a Wire object and closed.
Additional InformationOS: Debian GNU/Linux 9.4 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.
Build type: None
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsSVG
FreeCAD Information

Relationships

related to 0003483 acknowledged Simple paths cannot be upgraded 

Activities

steelman

2018-05-18 08:46

reporter   ~0011259

The attached file contains four paths to demonstrate the problem. The problem described above can be triggered by an attempt to import path №1 or №2 (one at a time). If upgraded together (both selected) they are upgraded properly to a Block without closing any of them.

paths.svg (6,925 bytes)

Kunda1

2018-05-29 19:50

administrator   ~0011301

Please follow the orientation in 0003483:0011299

Kunda1

2018-06-17 18:21

administrator   ~0011449

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=29340

Kunda1

2018-06-25 12:59

administrator   ~0011468

@bejant care to weigh in?

Kunda1

2018-06-26 10:33

administrator   ~0011473

Per bejamt (thanks btw!) this issue is still reproducible on 0.17 and 0.18dev
https://forum.freecadweb.org/viewtopic.php?f=8&t=29340#p241121

steelman

2018-08-19 13:29

reporter   ~0011630

Still broken in

OS: Debian GNU/Linux 9.5 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13528 (Git) AppImage
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 5c3f7bf8ec51e2c7187789f7edba71a7aa82a88b
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: Polish/Poland (pl_PL)

and

OS: Debian GNU/Linux 9.5 (stretch)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.5235 (Git shallow) AppImage
Build type: Release
Branch: master
Hash: 3e6cc7bbcd03ef2a9d57d504b0971c098e64171a
Python version: 3.6.5
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Polish/Poland (pl_PL)

normandc

2018-09-02 21:37

manager   ~0011690

Gift's reply in the topic created by Kunda1 clearly proves that it's working as designed, not a bug.

My question in 0003483 stands, what would be the reason to upgrade a single edge path in the first place. Hence, this should have been discussed over the forum before creating this issue.

normandc

2018-09-02 21:41

manager   ~0011691

https://www.freecadweb.org/wiki/Draft_Upgrade


  • if there is only one open wire in the selection, it gets closed
  • if there are only edges in the selection, all edges are joined into a wire (closed if possible)

The wiki

normandc

2018-09-22 19:18

manager   ~0011822

As per my previous comment, the tool works just as advertised.

Issue History

Date Modified Username Field Change
2018-05-18 07:46 steelman New Issue
2018-05-18 08:46 steelman File Added: paths.svg
2018-05-18 08:46 steelman Note Added: 0011259
2018-05-29 19:49 Kunda1 Relationship added related to 0003483
2018-05-29 19:50 Kunda1 Status new => feedback
2018-05-29 19:50 Kunda1 Note Added: 0011301
2018-06-17 18:21 Kunda1 Note Added: 0011449
2018-06-17 18:23 Kunda1 Tag Attached: SVG
2018-06-25 12:59 Kunda1 Note Added: 0011468
2018-06-26 10:33 Kunda1 Status feedback => confirmed
2018-06-26 10:33 Kunda1 Target Version => 0.18
2018-06-26 10:33 Kunda1 Note Added: 0011473
2018-08-19 13:29 steelman Note Added: 0011630
2018-09-02 21:37 normandc Note Added: 0011690
2018-09-02 21:41 normandc Note Added: 0011691
2018-09-22 19:18 normandc Assigned To => normandc
2018-09-22 19:18 normandc Status confirmed => closed
2018-09-22 19:18 normandc Resolution open => no change required
2018-09-22 19:18 normandc Note Added: 0011822