View Issue Details

IDProjectCategoryView StatusLast Update
0003482PartDesignBugpublic2018-12-24 12:46
Reporterctrlbru Assigned Tochrisb  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx68-64OSLinux MintOS Version18.3
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003482: Segfault when adding Fillet
DescriptionApplying a fillet in part design to a specific edge of the attached file gives a segfault.
Program received signal SIGSEGV, Segmentation fault.
#0  /lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7f472f7754b0]
#1  0x7f46b49fa1a4 in Geom2d_Curve::Value(double) const from /usr/lib/x86_64-linux-gnu/libTKG2d.so.7+0x14
0000002  0x7f46b50cce5b in ChFi3d_Builder::PerformMoreThreeCorner(int, int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x97eb
0000003  0x7f46b50a8ef7 in ChFi3d_Builder::PerformIntersectionAtEnd(int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x1257
0000004  0x7f46b50b6cd0 in ChFi3d_Builder::PerformOneCorner(int, bool) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x3c80
0000005  0x7f46b50533d3 in ChFi3d_Builder::PerformFilletOnVertex(int) from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x503
0000006  0x7f46b505439f in ChFi3d_Builder::Compute() from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0xebf
0000007  0x7f46b51df0a3 in BRepFilletAPI_MakeFillet::Build() from /usr/lib/x86_64-linux-gnu/libTKFillet.so.7+0x33
0000008  0x7f46b54d9128 in PartDesign::Fillet::execute() from /usr/lib/freecad/lib/_PartDesign.so+0x498
0000009  0x7f4731cbc319 in App::DocumentObject::recompute() from /usr/lib/freecad/lib/libFreeCADApp.so+0x79
0000010  0x7f46ad01bdcb in Part::Feature::recompute() from /usr/lib/freecad/lib/Part.so+0xb
0000011  0x7f4731c860ac in App::Document::_recomputeFeature(App::DocumentObject*) from /usr/lib/freecad/lib/libFreeCADApp.so+0xac
0000012  0x7f4731c8eac0 in App::Document::recompute() from /usr/lib/freecad/lib/libFreeCADApp.so+0x1f0
0000013  0x7f4731ce7b72 in App::DocumentPy::recompute(_object*) from /usr/lib/freecad/lib/libFreeCADApp.so+0x42
0000014  0x7f4731ce7ce7 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from /usr/lib/freecad/lib/libFreeCADApp.so+0x37
0000015  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x8a51) [0x7f473133b971]
0000016  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x85c) [0x7f473147105c]
0000017  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCode+0x19) [0x7f4731332da9]
0000018  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyRun_StringFlags+0x76) [0x7f47313ad1f6]
0000019  0x7f47318c3916 in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib/freecad/lib/libFreeCADBase.so+0x66
0000020  0x7f47323e12a0 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /usr/lib/freecad/lib/libFreeCADGui.so+0x130
0000021  0x7f47323e1bf4 in Gui::Command::updateActive() from /usr/lib/freecad/lib/libFreeCADGui.so+0x34
0000022  0x7f46aa4bec65 in finishFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, App::DocumentObject*, bool, bool) from /usr/lib/freecad/lib/PartDesignGui.so+0x125
0000023  0x7f46aa4bf5c7 in finishDressupFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, Part::Feature*, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&) from /usr/lib/freecad/lib/PartDesignGui.so+0x477
0000024  0x7f46aa4c1b2a in makeChamferOrFillet(Gui::Command*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) from /usr/lib/freecad/lib/PartDesignGui.so+0x12a
0000025  0x7f46aa4c1c66 in CmdPartDesignFillet::activated(int) from /usr/lib/freecad/lib/PartDesignGui.so+0x46
0000026  0x7f47323e563c in Gui::Command::invoke(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x7c
0000027  0x7f4730241010 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x4d0
0000028  0x7f4730753d62 in QAction::triggered(bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x42
0000029  0x7f47307550b3 in QAction::activate(QAction::ActionEvent) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x83
0000030  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x5a0623) [0x7f4730b35623]
0000031  0x7f4730b35774 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x74
0000032  0x7f4730bfb73a in QToolButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0xa
0000033  0x7f47307b08d0 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x2a0
0000034  0x7f4730759fdc in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x8c
0000035  0x7f47307610d6 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x476
0000036  0x7f47323c0464 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x54
0000037  0x7f473022c90d in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x8d
0000038  0x7f47307606dd in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x14d
#39  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2493f2) [0x7f47307de3f2]
#40  0x7f47307ddc83 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x16b3
0000041  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272542) [0x7f4730807542]
0000042  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2a7) [0x7f4728dc6197]
0000043  /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4a3f0) [0x7f4728dc63f0]
0000044  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7f4728dc649c]
0000045  0x7f473025d2ae in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x7e
0000046  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272616) [0x7f4730807616]
0000047  0x7f473022b18f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x3f
0000048  0x7f473022b4f5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x1b5
0000049  0x7f47302314b9 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x99
0000050  0x7f4732379240 in Gui::Application::runApplication() from /usr/lib/freecad/lib/libFreeCADGui.so+0x15b0
0000051  freecad(main+0x8b4) [0x403804]
0000052  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f472f760830]
0000053  freecad(_start+0x29) [0x404a49]
Steps To ReproduceOpen the attached example
Switch to PartDesign
Try to apply Fillet to the highlighted edge

Additional InformationOS: Linux Mint 18.3 Sylvia
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13522 (Git)
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 3bb5ff4e70c0c526f2d9dd69b1004155b2f527f2
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Italian/Italy (it_IT)
Tagscrash
FreeCAD Information

Activities

ctrlbru

2018-05-17 18:45

reporter  

miao1.fcstd (80,696 bytes)

Kunda1

2018-05-29 19:38

administrator   ~0011295

@chrisb please test, thanks!

chrisb

2018-05-30 19:52

developer   ~0011310

FreeCAD does not crash.
The fillet is not created due to the arbitrary small radius touching at the end of the edge.

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13826 (Git)
Build type: Release
Branch: (HEAD detached at 3b02ff2)
Hash: 3b02ff2a9481f0883063c7e24c312978ef0ce642
Python version: 2.7.15
Qt version: 5.11.0
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)

Issue History

Date Modified Username Field Change
2018-05-17 18:45 ctrlbru New Issue
2018-05-17 18:45 ctrlbru Tag Attached: crash
2018-05-17 18:45 ctrlbru Tag Attached: Fillet Selected Edges
2018-05-17 18:45 ctrlbru File Added: miao1.fcstd
2018-05-29 19:38 Kunda1 Note Added: 0011295
2018-05-30 19:52 chrisb Note Added: 0011310
2018-05-30 19:53 chrisb Assigned To => chrisb
2018-05-30 19:53 chrisb Status new => closed
2018-05-30 19:53 chrisb Resolution open => fixed
2018-05-30 19:53 chrisb Fixed in Version => 0.18
2018-12-24 12:46 Kunda1 Tag Detached: Fillet Selected Edges