View Issue Details

IDProjectCategoryView StatusLast Update
0000347FreeCADFeaturepublic2011-05-21 07:33
Reporterpperisin Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000347: Update CATIA-like rotation for CAD navigation
DescriptionHi,

I do not know, but I think that CATIA used to rotate if you would hold MMB + LMB together.

Right now with this CATIA supports MMB + RMB for rotation too. This is the way most people rotate in CATIA now, since it is much easier to use index finger than middle finger for wheel click. Also, when I started working in FreeCAD it seemed pretty hard and strange to use middle finger for wheel click.

Can the command for rotation be updated with this way of rotation. I know that there is also inventor navigation but I do not like it because then I need to hold CTRL for some commands, and so on.

Regards,
Petar Perisin
TagsNo tags attached.
FreeCAD Information

Relationships

has duplicate 0000253 closedwmayer Implement alternative CAD navigation style 

Activities

Jriegel

2011-05-17 10:34

administrator   ~0000833

Its OK by me. But a very minor feature.

wmayer

2011-05-21 07:33

administrator   ~0000853

Done in r4507

Issue History

Date Modified Username Field Change
2011-05-11 12:18 pperisin New Issue
2011-05-17 10:34 Jriegel Note Added: 0000833
2011-05-17 10:34 Jriegel Status new => confirmed
2011-05-17 10:41 Jriegel Status confirmed => acknowledged
2011-05-21 07:31 wmayer Relationship added has duplicate 0000253
2011-05-21 07:33 wmayer Note Added: 0000853
2011-05-21 07:33 wmayer Status acknowledged => closed
2011-05-21 07:33 wmayer Resolution open => fixed
2011-05-21 07:33 wmayer Fixed in Version => 0.12