View Issue Details

IDProjectCategoryView StatusLast Update
0003430ArchBugpublic2018-05-28 13:26
ReportercynabrAssigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformpcOSlinux 64bitOS Versionmint 18.1 serena
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003430: application crashes when create wall object from 2-point line or restangle
Descriptionapplication crashes when create wall object from 2-point line or restangle.
Приложение падает при попытке создать стену из линии, прямоугольника, многоугольника, окружности ets...

Is observed only in the Russian localization.
https://youtu.be/nsdc26lCarc (link to effect demonstration)


~ $ freecad
FreeCAD 0.17, Libs: 0.17R13509 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Fasteners workbench Loaded
Sheet Metal workbench loaded
Program received signal SIGSEGV, Segmentation fault.
#0  /lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7fc132fad4b0]
#1  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyString_AsString+0x4) [0x7fc134bb7844]
0000002  0x7fc13551e720 in App::DocumentPy::openTransaction(_object*) from /usr/lib/freecad/lib/libFreeCADApp.so+0x140

0000003  0x7fc13551e7e7 in App::DocumentPy::staticCallback_openTransaction(_object*, _object*) from /usr/lib/freecad/lib/libFreeCADApp.so+0x37

0000004  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x8a51) [0x7fc134b73971]
0000005  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x85c) [0x7fc134ca905c]
0000006  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(+0x13e370) [0x7fc134bff370]
0000007  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyObject_Call+0x43) [0x7fc134bd2273]
0000008  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(+0x1853ac) [0x7fc134c463ac]
0000009  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyObject_Call+0x43) [0x7fc134bd2273]
0000010  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_CallObjectWithKeywords+0x47) [0x7fc134ca8487]

0000011  /usr/lib/freecad/lib/libFreeCADBase.so(PP_Run_Method+0xe7) [0x7fc1351716c7]
0000012  0x7fc1350fc8f9 in Base::InterpreterSingleton::runMethodVoid(_object*, char const*) from /usr/lib/freecad/lib/libFreeCADBase.so+0x29

0000013  0x7fc135c1aace in Gui::PythonCommand::activated(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x9e

0000014  0x7fc135c1d63c in Gui::Command::invoke(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x7c
0000015  0x7fc133a78f80 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x4d0

0000016  0x7fc133f8ad62 in QAction::triggered(bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x42
0000017  0x7fc133f8c0b3 in QAction::activate(QAction::ActionEvent) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x83

0000018  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x5a0cd3) [0x7fc13436ccd3]
0000019  0x7fc13436ce24 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x74

0000020  0x7fc134432dea in QToolButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0xa

0000021  0x7fc133fe78d0 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x2a0
0000022  0x7fc133f90fdc in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x8c

0000023  0x7fc133f980d6 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x476

0000024  0x7fc135bf8464 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x54

0000025  0x7fc133a648bd in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x8d

0000026  0x7fc133f976dd in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, 
QWidget**, QPointer<QWidget>&, bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x14d
0000027  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2493f2) [0x7fc1340153f2]
0000028  0x7fc134014c83 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x16b3

0000029  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272542) [0x7fc13403e542]
0000030  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2a7) [0x7fc12c6cc197]
0000031  /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4a3f0) [0x7fc12c6cc3f0]
0000032  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7fc12c6cc49c]
0000033  0x7fc133a9521e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) 
from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x7e
0000034  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272616) [0x7fc13403e616]
0000035  0x7fc133a6313f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x3f

0000036  0x7fc133a634a5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x1b5

0000037  0x7fc133a69469 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x99
0000038  0x7fc135bb1240 in Gui::Application::runApplication() from /usr/lib/freecad/lib/libFreeCADGui.so+0x15b0

#39  freecad(main+0x8b4) [0x403804]
#40  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fc132f98830]
0000041  freecad(_start+0x29) [0x404a49]
Укажите первую точку Укажите следующую точку cynabr@linux-2mol 
~ $ 
Steps To Reproduce1 -start freecad
2 -go to preference
3 -select a russian language
4 -aply
5 -go to arch worcbench
6 -create a 2-point line
7 -create from line wall
TagsArch, crash

Relationships

related to 0003423 assignedyorik Error message generated when creating wall from dwire or sketch 

Activities

cynabr

2018-04-14 18:51

reporter  

g13.mp4 (742,137 bytes)

Kunda1

2018-04-15 17:02

administrator   ~0011144

@DeepSOIC care to check this bug (since you use a russian locale AFAIR) ?

DeepSOIC

2018-04-15 19:06

developer   ~0011158

Last edited: 2018-04-15 19:07

View 2 revisions

@Kunda1 I use English version. FC reports my system locale, not freecad's UI language.

I can confirm the bug. In Russian interface, creation of arch wall fails for me, with "unknown c++ exception" printed to report view (which usually means a crash on systems other than Windows).

In report view, I get:
container changed from None to _________________
Loading Draft module...done
Draft workbench activated
Loading Arch module... done
Draft workbench deactivated
Arch workbench activated
created object
Укажите первую точку Укажите следующую точку deleted __________. container chain: _________________
created object
Running the Python command 'Arch_Wall' failed:
Traceback (most recent call last):
  File "S:\_vt\dev\PC\Qt\FreeCAD\builds-snapshots\Default\Mod\Arch\ArchWall.py", line 194, in Activated
    FreeCAD.ActiveDocument.openTransaction(translate("Arch","Create Wall"))

Unknown C++ exceptionHide main window
Show main window



Kunda1

2018-04-25 13:12

administrator   ~0011198

Thanks DeepSOIC (and noted about the locale assumption I made)
@yorik care to weigh in ?

yorik

2018-05-28 13:26

administrator   ~0011288

This is now fixed with https://github.com/FreeCAD/FreeCAD/commit/4f5e304d64d79eb64d3b96f41cdc5293522958ef

Issue History

Date Modified Username Field Change
2018-04-14 18:51 cynabr New Issue
2018-04-14 18:51 cynabr File Added: g13.mp4
2018-04-14 18:51 cynabr Tag Attached: Arch
2018-04-14 18:51 cynabr Tag Attached: crash
2018-04-15 17:02 Kunda1 Note Added: 0011144
2018-04-15 19:06 DeepSOIC Note Added: 0011158
2018-04-15 19:07 DeepSOIC Note Edited: 0011158 View Revisions
2018-04-25 12:55 Kunda1 Relationship added related to 0003423
2018-04-25 13:12 Kunda1 Note Added: 0011198
2018-05-28 13:26 yorik Assigned To => yorik
2018-05-28 13:26 yorik Status new => closed
2018-05-28 13:26 yorik Resolution open => fixed
2018-05-28 13:26 yorik Fixed in Version => 0.18
2018-05-28 13:26 yorik Note Added: 0011288