View Issue Details

IDProjectCategoryView StatusLast Update
0003426FreeCADBugpublic2018-04-17 16:21
Reportereasyw-fcAssigned Topeterl94 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003426: STEP exporting regression
Descriptionbug in STEP exporter on stable release FreeCAD-0.17.13509.0258808
When exporting a hierarchical STEP, nothing get exported and the result file is empty.

Everything worked fine until release FreeCAD_0.17.13488
Steps To ReproduceOpen the hierarchical STEP file 'd488.step' in FC0.17-509 and select the Part top level container, then export the selection as STEP through the file menu.
The exported STEP file 'd509.step' will be empty.
Those exporting operation worked fine at least until FC0.17-13488 (I don't have intermediate releases between tose two).
Same issue on FC0.18-13516
TagsOCC 7.2, STEP

Activities

easyw-fc

2018-04-11 21:25

reporter  

d509.step (1,667 bytes)
d488.step (978,489 bytes)

easyw-fc

2018-04-11 21:35

reporter   ~0011141

Last edited: 2018-04-11 21:55

View 2 revisions

This seems related to the interaction of OCC7.2 code and the FC exporting routines ... I verified this issue also on FC0.17-13452 Conda build, where the FC release was prior to 13488, but OCC was already 7.2

peterl94

2018-04-17 16:21

developer   ~0011167

https://github.com/FreeCAD/FreeCAD/commit/72d334d867575059d1336870a212c2e0d4d403ac

Issue History

Date Modified Username Field Change
2018-04-11 21:25 easyw-fc New Issue
2018-04-11 21:25 easyw-fc File Added: d509.step
2018-04-11 21:25 easyw-fc File Added: d488.step
2018-04-11 21:25 easyw-fc Tag Attached: STEP
2018-04-11 21:35 easyw-fc Tag Attached: OCC 7.2
2018-04-11 21:35 easyw-fc Note Added: 0011141
2018-04-11 21:55 easyw-fc Note Edited: 0011141 View Revisions
2018-04-17 16:21 peterl94 Assigned To => peterl94
2018-04-17 16:21 peterl94 Status new => closed
2018-04-17 16:21 peterl94 Resolution open => fixed
2018-04-17 16:21 peterl94 Fixed in Version => 0.17
2018-04-17 16:21 peterl94 Note Added: 0011167