View Issue Details

IDProjectCategoryView StatusLast Update
0003416FreeCADBugpublic2018-04-04 14:12
Reporterpager48 Assigned Towmayer  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003416: Crash on draft operation for a face
DescriptionUsing


OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13483 (Git) AppImage
Build type: None
Branch: master
Hash: 0ac32464e45fa9648cdaf702ebda06650dabe9dc
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
Steps To Reproduce-Open part named "crasher"
-Select top or bottom face
-Try to draft

Results: crash
TagsNo tags attached.

Activities

pager48

2018-04-01 01:12

reporter  

crasher.fcstd (11,682 bytes)

Kunda1

2018-04-01 12:40

administrator   ~0011093

@chrisb can you confirm?

Chris_G

2018-04-03 19:54

developer   ~0011115

Nothing wrong here. No crash.
I am able to draft on top or bottom face.
OS: Ubuntu 17.10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13491 (Git)
Build type: Unknown
Branch: master
Hash: ba3fb75b48962f4b78c6e3ebdebf3965e35aa1e4
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: French/France (fr_FR)

chrisb

2018-04-03 20:25

developer   ~0011116

I can confirm the crash here. Th crash occurs immediately after selecteing the top face and clicking PartDesign->Draft.

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13483 (Git)
Build type: Release
Branch: (HEAD detached at 0ac3246)
Hash: 0ac32464e45fa9648cdaf702ebda06650dabe9dc
Python version: 2.7.14
Qt version: 5.10.1
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)

chrisb

2018-04-03 20:35

developer   ~0011117

Can confirm with the most recent version as well:

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13498 (Git)
Build type: Release
Branch: (HEAD detached at 85b42a1)
Hash: 85b42a16d960c4ca11dbb8288ad08cf12a0291dc
Python version: 2.7.14
Qt version: 5.10.1
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: German/Germany (de_DE)

Chris_G

2018-04-03 20:38

developer   ~0011118

My bad. I was testing the Draft WB.
I was not aware of this PartDesign.Draft tool.
It crashes also for me :
Log: Loading PartDesign module... done
Log: Loading GUI of PartDesign module... done
Log: X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 31 (X_GrabKeyboard)
  Resource id:  0x0
Err: Program received signal SIGSEGV, Segmentation fault.
Err: #0  /lib/x86_64-linux-gnu/libc.so.6(+0x37140) [0x7fbc69c7d140]
Err: #1  0x7fbc1dde6730 in Geom_Circle::Circ() const from /usr/local/lib/libTKG3d.so.7+0
Err: 0000002  0x7fbc1de0bf46 in GeomAdaptor_Curve::Circle() const from /usr/local/lib/libTKG3d.so.7+0x56
Err: 0000003  0x7fbc1bb155de in BRepAdaptor_Curve::Circle() const from /usr/local/lib/libTKBRep.so.7+0x25e
Err: 0000004  0x7fbc09fa0c75 in PartDesign::Draft::execute() from /home/tomate/Software/FreeCAD/build/Mod/PartDesign/_PartDesign.so+0x81b
Err: 0000005  0x7fbc6c64440f in App::DocumentObject::recompute() from /home/tomate/Software/FreeCAD/build/lib/libFreeCADApp.so+0xbd
Err: 0000006  0x7fbc1f00f8cb in Part::Feature::recompute() from /home/tomate/Software/FreeCAD/build/Mod/Part/Part.so+0x1b
Err: 0000007  0x7fbc6c5da5eb in App::Document::_recomputeFeature(App::DocumentObject*) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADApp.so+0xa5
Err: 0000008  0x7fbc6c5d8fcc in App::Document::recompute() from /home/tomate/Software/FreeCAD/build/lib/libFreeCADApp.so+0x324
Err: 0000009  0x7fbc6c6857e4 in App::DocumentPy::recompute(_object*) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADApp.so+0x5e
Err: 0000010  0x7fbc6c67f563 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADApp.so+0x119
Err: 0000011  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x9179) [0x7fbc6b860b09]
Err: 0000012  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x7d8) [0x7fbc6b988b88]
Err: 0000013  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyEval_EvalCode+0x19) [0x7fbc6b8577f9]
Err: 0000014  /usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0(PyRun_StringFlags+0x76) [0x7fbc6b900e76]
Err: 0000015  0x7fbc6be91991 in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADBase.so+0xe7
Err: 0000016  0x7fbc6d2a81e5 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x197
Err: 0000017  0x7fbc6d2a8aaa in Gui::Command::updateActive() from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x3a
Err: 0000018  0x7fbc09a239ec in finishFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, App::DocumentObject*, bool, bool) from /home/tomate/Software/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0xa6
Err: 0000019  0x7fbc09a27b0b in finishDressupFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, Part::Feature*, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&) from /home/tomate/Software/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x46c
Err: 0000020  0x7fbc09a284e0 in CmdPartDesignDraft::activated(int) from /home/tomate/Software/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x40c
Err: 0000021  0x7fbc6d2a785e in Gui::Command::invoke(int) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x9a
Err: 0000022  0x7fbc6d29b001 in Gui::Action::onActivated() from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x21
Err: 0000023  /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so(+0x7c03b6) [0x7fbc6d2a03b6]
Err: 0000024  0x7fbc6a761f70 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x4d0
Err: 0000025  0x7fbc6ac73dc2 in QAction::triggered(bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x42
Err: 0000026  0x7fbc6ac75113 in QAction::activate(QAction::ActionEvent) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x83
Err: 0000027  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x5a0fa3) [0x7fbc6b055fa3]
Err: 0000028  0x7fbc6b0560f4 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x74
Err: 0000029  0x7fbc6b11c0aa in QToolButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0xa
Err: 0000030  0x7fbc6acd0930 in QWidget::event(QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x2a0
Err: 0000031  0x7fbc6ac7a03c in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x8c
Err: 0000032  0x7fbc6ac81136 in QApplication::notify(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x476
Err: 0000033  0x7fbc6d273ca2 in Gui::GUIApplication::notify(QObject*, QEvent*) from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x10e
Err: 0000034  0x7fbc6a74d8ad in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x8d
Err: 0000035  0x7fbc6ac8073d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x14d
Err: 0000036  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x249452) [0x7fbc6acfe452]
Err: 0000037  0x7fbc6acfdce3 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/x86_64-linux-gnu/libQtGui.so.4+0x16b3
Err: 0000038  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272592) [0x7fbc6ad27592]
Err: #39  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x2e7) [0x7fbc63ab6fb7]
Err: #40  /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4b1f0) [0x7fbc63ab71f0]
Err: 0000041  /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x7fbc63ab727c]
Err: 0000042  0x7fbc6a77e20e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x7e
Err: 0000043  /usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x272666) [0x7fbc6ad27666]
Err: 0000044  0x7fbc6a74c12f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x3f
Err: 0000045  0x7fbc6a74c495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x1b5
Err: 0000046  0x7fbc6a752459 in QCoreApplication::exec() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4+0x99
Err: 0000047  0x7fbc6d201b93 in Gui::Application::runApplication() from /home/tomate/Software/FreeCAD/build/lib/libFreeCADGui.so+0x1ec3
Err: 0000048  /home/tomate/Software/FreeCAD/build/bin/FreeCAD(main+0xa89) [0x56450f6f20e3]
Err: 0000049  /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7fbc69c671c1]
Err: 0000050  /home/tomate/Software/FreeCAD/build/bin/FreeCAD(_start+0x2a) [0x56450f6f14ba]

Kunda1

2018-04-03 23:34

administrator   ~0011119

Thanks fellas. Assigned to wmayer to address pre-release.

wmayer

2018-04-04 14:12

administrator   ~0011122

Doesn't happen in debug mode of OCC because it does a type check and raises an exception because the type is a b-spline. In release mode no type is done causing to access a null pointer.

Fixed in https://github.com/FreeCAD/FreeCAD/commit/1b49a006cd453f84cb78bb07e498b49322c06cb1

Issue History

Date Modified Username Field Change
2018-04-01 01:12 pager48 New Issue
2018-04-01 01:12 pager48 File Added: crasher.fcstd
2018-04-01 12:40 Kunda1 Note Added: 0011093
2018-04-02 17:19 Kunda1 Product Version 0.18 => 0.17
2018-04-03 19:54 Chris_G Note Added: 0011115
2018-04-03 20:25 chrisb Note Added: 0011116
2018-04-03 20:35 chrisb Note Added: 0011117
2018-04-03 20:38 Chris_G Note Added: 0011118
2018-04-03 23:34 Kunda1 Assigned To => wmayer
2018-04-03 23:34 Kunda1 Status new => assigned
2018-04-03 23:34 Kunda1 Note Added: 0011119
2018-04-04 14:12 wmayer Status assigned => closed
2018-04-04 14:12 wmayer Resolution open => fixed
2018-04-04 14:12 wmayer Fixed in Version => 0.17
2018-04-04 14:12 wmayer Note Added: 0011122