View Issue Details

IDProjectCategoryView StatusLast Update
0003401PartDesignBugpublic2018-09-16 14:27
ReporterfreedmanAssigned Towandererfan 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindowsOS Version7.0
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003401: Sketch goes to pad and the pad vanishes without explaination, please add warning message
DescriptionIn Part design (workbench) only a single solid is allowed to be drawn kind-of. If a first solid is created followed by a second sketch that isn't connected to the prior solid, when the second sketch goes to solid, the object and sketch disappear from the view screen. Apparently this is by design to instruct the user that this action is not allowed, but without any real instruction. The user gets no message, just a disappearing part. All I'm asking for is a warning message "Broken part, has to be single solid". I don't even mind the part disappearing, just needs a warning pop-up and a "OK" button.

My best detection mode would be to detect a broken solid, different options like revolve, loft, pad can make this occur. This vanishing thing is designed to not occur in "Part", it's OK to have 2 solids there.
Steps To ReproduceIn part design, New Body, New sketch XY plane
Draw square anywhere, close that, Pad it
Open another sketch xy plane, the prior box is shown
Draw square anywhere non-intersecting next to the prior square, close that, pad it and the part vanishes.
Additional InformationThank you. This could be big help for first time users, I originally thought the program was full of bugs because parts just disappear. This action is very unprofessional to me.
TagsNo tags attached.

Relationships

duplicate of 0001707 closedwandererfan PartDesign - Inconsistent handling of multiple pieces 

Activities

Kunda1

2018-03-29 10:58

manager   ~0011078

@freedman please always include your Help > About FreeCAD > Copy to clipboard so we know the specifics of the version you're using. Also please read the https://freecadweb.org/wiki/Tracker page to correctly submit a ticket to our bugtracker. Thank you.

@normandc care to weigh in on this ?

freedman

2018-03-29 18:26

reporter   ~0011080

Last edited: 2018-03-30 18:26

View 5 revisions

viewtopic.php?f=3&t=27672
viewtopic.php?f=3&t=27631
viewtopic.php?f=8&t=27772

Maybe the best warning I have seen as yet " In one body can only exist one solid"

Sorry, I thought I did this:
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12643 (Git)
Build type: Release
Branch: master
Hash: 868d9cc6c215ce3a2ab20d454378ec00e1b9ed26
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

Kunda1

2018-03-29 19:44

manager   ~0011081

We're currently on revision Version: 0.17.13472 (Git)
You're using Version: 0.17.12643 (Git)
Please update and retest

freedman

2018-03-30 04:28

reporter   ~0011083

Last edited: 2018-03-30 04:44

View 2 revisions

The latest I see is 0.17.13452, that is what I'm using now. Still there, I believe this will occur in all versions, one moderator said something about years it has been like this. If you can point me to 0.17.13472 I will use it.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13452 (Git)
Build type: Release
Branch: master
Hash: 34633c144de9133c1f9aeb7da783f369cae9bfaf
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

normandc

2018-04-06 23:07

manager   ~0011134

There is no test needed, what freedman wrote is correct, and brings confusion to new users. Although I think sorting it as a bug is rather strong (but there is no other appropriate category), it is certainly a usability issue.

FYI there is another report about this. Will find and add relationship.

chrisb

2018-04-06 23:09

developer   ~0011135

This is not a bug, it's a feature request.

wandererfan

2018-04-08 13:55

developer   ~0011136

Are there any circumstances when a PD Body is allowed to have >1 solid? Interim result?
Very odd case?

normandc

2018-04-08 14:16

manager   ~0011137

Last edited: 2018-04-08 14:17

View 2 revisions

No (to the laments of some users). If I recall correctly it's both a design choice and a technical limitation, but couldn't say how.

There is currently one way to trick it to support more than one solid: sketch multiple separate profiles independently from a Body, Part Extrude instead of Pad, then create a Body with Extrude selected. This creates a new Body with a BaseFeature containing multiple solids. But as soon as you add a PD additive or subtractive feature, the single body rule is enforced again.

normandc

2018-09-16 14:27

manager   ~0011757

This was fixed on July 13th 2018 in the releases/FreeCAD-0-17 branch by adding a warning message. Related commits are 1889f1f8, 1dd565ee and 5c3f7bf8. This fix is included in FreeCAD 0.17.13528 or later.

Issue History

Date Modified Username Field Change
2018-03-26 23:24 freedman New Issue
2018-03-29 10:58 Kunda1 Note Added: 0011078
2018-03-29 10:58 Kunda1 Status new => feedback
2018-03-29 18:26 freedman Note Added: 0011080
2018-03-29 18:26 freedman Status feedback => new
2018-03-29 18:27 freedman Note Edited: 0011080 View Revisions
2018-03-29 18:49 freedman Note Edited: 0011080 View Revisions
2018-03-29 19:21 freedman Note Edited: 0011080 View Revisions
2018-03-29 19:44 Kunda1 Note Added: 0011081
2018-03-30 04:28 freedman Note Added: 0011083
2018-03-30 04:44 freedman Note Edited: 0011083 View Revisions
2018-03-30 18:26 freedman Note Edited: 0011080 View Revisions
2018-04-06 23:07 normandc Note Added: 0011134
2018-04-06 23:09 chrisb Note Added: 0011135
2018-04-06 23:10 normandc Relationship added duplicate of 0001707
2018-04-08 13:54 wandererfan Assigned To => wandererfan
2018-04-08 13:54 wandererfan Status new => assigned
2018-04-08 13:55 wandererfan Note Added: 0011136
2018-04-08 14:16 normandc Note Added: 0011137
2018-04-08 14:17 normandc Note Edited: 0011137 View Revisions
2018-04-20 17:15 wandererfan Assigned To wandererfan =>
2018-04-20 17:19 wandererfan Assigned To => wandererfan
2018-04-20 17:19 wandererfan Status assigned => confirmed
2018-04-21 15:24 wandererfan Assigned To wandererfan =>
2018-09-16 14:27 normandc Assigned To => wandererfan
2018-09-16 14:27 normandc Status confirmed => closed
2018-09-16 14:27 normandc Resolution open => fixed
2018-09-16 14:27 normandc Fixed in Version => 0.17
2018-09-16 14:27 normandc Note Added: 0011757