View Issue Details

IDProjectCategoryView StatusLast Update
0003389DraftBugpublic2018-12-28 02:19
ReporterrandallAssigned Towandererfan 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionno change required 
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003389: Using Draft-PathArray on a Sketcher Arc with Align=True results in "Value out of range"
DescriptionWhen using the Draft PathArray to align on object on a Sketch Arc the Object is aligned correctly initially but when the Arc Radius is changed or the Arc Angle is changed a Value out of Range error is produced. However the error does not happen for every resize.

I have reported this on Forum at: https://forum.freecadweb.org/viewtopic.php?f=10&t=27428

I made a screen cap at:

https://youtu.be/MVLm1e3z5vI
Steps To Reproduce1.) In Part Design WB create an Additive Cube. ( or any object )
2.) Create a second body with a Sketch and an Arc.
3.) Switch to Draft WB
4.) Select Cube and Arc, click PathArray Tool
5.) In resulting array change the Align property to true
6.) edit the arc sketch and increase/decrease it's size until you get error

It seems larger changes produce the error more reliably.
It also seems like the closer to the object the path is the less likely to get an error.
Additional InformationMy FreeCAD Info:

OS: Linux Mint 17.3 Rosa
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.17.13424 (Git)
Build type: None
Branch: master
Hash: 597dbf60947067852268033c32d6b78ac9ef280c
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)


Report View:

Traceback (most recent call last):
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5662, in execute
    obj.Shape = self.pathArray(obj.Base.Shape,w,obj.Count,obj.Xlate,obj.Align)
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5767, in pathArray
    ns = self.orientShape(shape,path[-1],path[-1].Length,pt,xlate,align,normal)
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5709, in orientShape
    t = edge.tangentAt(self.getParameterFromV0(edge,offset))
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5688, in getParameterFromV0
    return(edge.getParameterByLength(length))
<type 'exceptions.ValueError'>: value out of range


Console:

Part::FeaturePython: Links go out of the allowed scope
Part::FeaturePython: Links go out of the allowed scope
Part::FeaturePython: Links go out of the allowed scope
Traceback (most recent call last):
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5662, in execute
    obj.Shape = self.pathArray(obj.Base.Shape,w,obj.Count,obj.Xlate,obj.Align)
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5767, in pathArray
    ns = self.orientShape(shape,path[-1],path[-1].Length,pt,xlate,align,normal)
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5709, in orientShape
    t = edge.tangentAt(self.getParameterFromV0(edge,offset))
  File "/usr/lib/freecad-daily/Mod/Draft/Draft.py", line 5688, in getParameterFromV0
    return(edge.getParameterByLength(length))
<type 'exceptions.ValueError'>: value out of range



TagsNo tags attached.

Relationships

related to 0003581 closedwandererfan Draft PathArray Align=True not work on custom sketch path 

Activities

Kunda1

2018-03-29 19:48

administrator   ~0011082

@yorik please weigh in at your convenience, thanks!

Kunda1

2018-11-19 10:32

administrator   ~0012219

@yorik what release should this be assigned to ?

wandererfan

2018-12-08 02:06

developer   ~0012244

I can't reproduce this on v0.18. Also the test file is not fully constrained and has redundant constraints.

The only error in v0.18 is "link go out of allowed scope".

PathArrayAlignedBugConstrained.fcstd (14,092 bytes)

wandererfan

2018-12-08 18:05

developer   ~0012245

marking this one "Resolved"

yorik

2018-12-28 02:18

administrator   ~0012343

I also did some testing and cannot reproduce the problem, I suppose it doesn't apply anymore...

Issue History

Date Modified Username Field Change
2018-03-22 14:59 randall New Issue
2018-03-29 19:48 Kunda1 Note Added: 0011082
2018-04-02 13:38 yorik Assigned To => yorik
2018-04-02 13:38 yorik Status new => assigned
2018-09-04 14:20 Kunda1 Relationship added related to 0003581
2018-11-19 10:32 Kunda1 Note Added: 0012219
2018-12-08 02:06 wandererfan File Added: PathArrayAlignedBugConstrained.fcstd
2018-12-08 02:06 wandererfan Note Added: 0012244
2018-12-08 18:05 wandererfan Assigned To yorik => wandererfan
2018-12-08 18:05 wandererfan Status assigned => resolved
2018-12-08 18:05 wandererfan Fixed in Version => 0.18
2018-12-08 18:05 wandererfan Target Version => 0.18
2018-12-08 18:05 wandererfan Note Added: 0012245
2018-12-28 02:18 yorik Note Added: 0012343
2018-12-28 02:18 yorik Status resolved => closed
2018-12-28 02:18 yorik Resolution open => fixed
2018-12-28 02:19 yorik Resolution fixed => no change required