View Issue Details

IDProjectCategoryView StatusLast Update
0003373FreeCADBugpublic2018-09-26 13:23
Reportergalou_breizhAssigned Towmayer 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003373: "Save a copy" of a document with a spreadsheet mark the document as touched
Description"Save a copy" of a document with a spreadsheet mark the document as touched.

Cf. https://forum.freecadweb.org/viewtopic.php?f=8&t=27466
Steps To ReproduceSteps to reproduce:
- Create a new document
- Create a new spreadsheet
- Save the document
- "File / Save a copy...", save a copy with a different file name
- The original document is marked as touched.
Additional InformationSeen on
OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13387 (Git)
Build type: None
Branch: master
Hash: c5f4079252b11e3c54cd603be7d3697fa9f9d922
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
Tagsspreadsheet

Activities

Kunda1

2018-08-01 13:25

administrator   ~0011578

@eivindkvedalen do you mind taking a look at this because it involves spreadsheets. If it's not something you know how to fix, let me know and I'll unassign you. Thanks!

wmayer

2018-09-26 11:24

administrator   ~0011850

That's mainly an issue the way how the saveCopy() function is implemented. It changes some properties of the document, saves it to a file and then restores the modified properties.
This however has the ugly side effect that certain features (like the spreadsheet) react on the changed properties.
IMO, the saveCopy function must work this way that it doesn't touch any document internals.

wmayer

2018-09-26 13:23

administrator   ~0011851

https://github.com/FreeCAD/FreeCAD/commit/dd492d74848a1583b8014d8893d037b93140c798

Issue History

Date Modified Username Field Change
2018-03-14 15:38 galou_breizh New Issue
2018-03-14 15:38 galou_breizh Tag Attached: spreadsheet
2018-03-15 21:03 Kunda1 Severity minor => major
2018-07-03 02:45 Kunda1 Target Version => 0.18
2018-08-01 13:24 Kunda1 Assigned To => eivindkvedalen
2018-08-01 13:24 Kunda1 Status new => assigned
2018-08-01 13:25 Kunda1 Note Added: 0011578
2018-09-26 11:24 wmayer Note Added: 0011850
2018-09-26 13:23 wmayer Assigned To eivindkvedalen => wmayer
2018-09-26 13:23 wmayer Status assigned => closed
2018-09-26 13:23 wmayer Resolution open => fixed
2018-09-26 13:23 wmayer Fixed in Version => 0.18
2018-09-26 13:23 wmayer Note Added: 0011851