View Issue Details

IDProjectCategoryView StatusLast Update
0003367TechDraw[FreeCAD] Bugpublic2018-04-23 07:36
ReporterreoxAssigned Towandererfan 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003367: view/data pane is unselected if hatch type is changed
DescriptionWhen changing the hatch type in the settings for a section view, immediately after the first character you type, the settings pane is closed with the log message:
While committing the data to the property the selection has changed.
Steps To ReproduceCreate a hatched surface and try to change "Name Geom Hatch" or "Hatch Scale" in the data pane
Additional InformationOS: Debian GNU/Linux testing (buster)
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13375 (Git)
Build type: None
Branch: master
Hash: 2bfea410fce1434fec0f853b032549aa2cd3c47e
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: German/Austria (de_AT)
TagsNo tags attached.

Activities

reox

2018-03-10 15:35

reporter   ~0011033

In this file, there is (for me) a 100% chance to trigger this bug

techdrawtest.fcstd (22,386 bytes)

wandererfan

2018-03-14 17:08

developer   ~0011042

This happens if a vertex/edge/face of the View is selected when the property is changed.
If the View is selected without geometry the message is not produced.

wandererfan

2018-03-20 12:39

developer   ~0011049

This is fixed in "test" environment, but the fix involves extensive changes to the TechDraw selection code. Since there is a work-around, I'm going to wait until the 0.17 release commotion dies down to merge.

wmayer

2018-04-23 07:36

administrator   ~0011180

https://github.com/FreeCAD/FreeCAD/commit/f13689753c130d9cac2e4f98df4953fe25c6c98f

Issue History

Date Modified Username Field Change
2018-03-10 12:57 reox New Issue
2018-03-10 15:35 reox File Added: techdrawtest.fcstd
2018-03-10 15:35 reox Note Added: 0011033
2018-03-14 17:08 wandererfan Note Added: 0011042
2018-03-20 12:39 wandererfan Assigned To => wandererfan
2018-03-20 12:39 wandererfan Status new => resolved
2018-03-20 12:39 wandererfan Target Version => 0.18
2018-03-20 12:39 wandererfan Note Added: 0011049
2018-04-23 07:36 wmayer Status resolved => closed
2018-04-23 07:36 wmayer Resolution open => fixed
2018-04-23 07:36 wmayer Fixed in Version => 0.18
2018-04-23 07:36 wmayer Note Added: 0011180