View Issue Details

IDProjectCategoryView StatusLast Update
0003365ArchBugpublic2019-01-18 13:50
ReporterzbiggAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.17 
Target Version0.18Fixed in Version0.18 
Summary0003365: Shift+B box selection DOES NOT deletes text nor dimension guide/helplines
Descriptionas above
Steps To Reproducehttps://www.freecadweb.org/wiki/Arch_tutorial

After importing DWG try to remove unwanted parts of the drawing with SHIFT+B
Additional InformationOS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13381 (Git)
Build type: Release
Branch: master
Hash: d95656d812f56da945f0624d8d4c70412ae17460
Python version: 3.6.4
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: Polish/Poland (pl_PL)
TagsNo tags attached.

Relationships

duplicate of 0002706 closedwmayer FreeCAD Box selection does not select dimension or text 

Activities

yorik

2018-03-10 21:37

administrator   ~0011034

The Box selection tool only "sees" Geom Features, which the Annotation object is not. Geom Features have a bound box, which is required by the box seleciton tool to work. So the annotation object should be turned into a geom feature, and its bound box calculated. But beter do that after the release...

wmayer

2019-01-18 13:50

administrator   ~0012459

https://github.com/FreeCAD/FreeCAD/commit/de5390456322afc5fc177a0544675355a6cb8664

The idea is not to change the type of an object but rather change the box selection. Instead of retrieving the bounding box of the geometry one can also compute a bounding box by applying an SoGetBoundingBoxAction on the Inventor sub-graph of a view provider.

Issue History

Date Modified Username Field Change
2018-03-09 22:26 zbigg New Issue
2018-03-09 22:26 zbigg Tag Attached: arch box selection text delete
2018-03-10 01:39 Kunda1 Tag Detached: arch box selection text delete
2018-03-10 21:37 yorik Note Added: 0011034
2018-03-10 21:37 yorik Assigned To => yorik
2018-03-10 21:37 yorik Status new => assigned
2018-03-12 09:38 wmayer Relationship added duplicate of 0002706
2018-12-05 13:08 yorik Target Version => 0.19
2019-01-18 13:50 wmayer Target Version 0.19 => 0.18
2019-01-18 13:50 wmayer Note Added: 0012459
2019-01-18 13:50 wmayer Status assigned => closed
2019-01-18 13:50 wmayer Resolution open => duplicate
2019-01-18 13:50 wmayer Fixed in Version => 0.18