View Issue Details

IDProjectCategoryView StatusLast Update
0003361Expressions[FreeCAD] Bugpublic2018-07-31 22:59
Reporter3DME Assigned Toeivindkvedalen  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003361: Spreadsheet: Inserting Row Cause Crash - FC Daily v0.17
DescriptionInserting a row in spreadsheet at row-2 causes FreeCAD to crash.

Help --> About FreeCAD, Version Info:
OS: Ubuntu 16.04.4 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13331 (Git)
Build type: None
Branch: master
Hash: e5ef0f532d7e733c581d587cb1c4796237912e03
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0aFollowing
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
Steps To ReproduceTo re-create the problem:
Open the project,
select the spreadsheet workbench,
open the spreadsheet,
right-click mouse on row-2 and select insert row, then FreeCAD crashes.

Additional InformationClick on the link below for additional information and to down load project files:

Link To Original Report: "On help using FreeCAD" Forum ...
TagsNo tags attached.

Relationships

has duplicate 0003390 closedeivindkvedalen FreeCAD FreeCAD crashes when inserting rows or columns into spreadsheet 

Activities

3DME

2018-03-02 01:09

reporter  

FreeCad_Debug_Terminal_text.txt (4,392 bytes)
raul@AMDQC:~$ cd '/usr/lib/freecad-daily/bin/' 
raul@AMDQC:/usr/lib/freecad-daily/bin$  gdb FreeCAD
GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.5) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from FreeCAD...(no debugging symbols found)...done.
(gdb) handle SIG33 noprint nostop
Signal        Stop	Print	Pass to program	Description
SIG33         No	No	Yes		Real-time event 33
(gdb) run
Starting program: /usr/lib/freecad-daily/bin/FreeCAD 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
FreeCAD 0.17, Libs: 0.17R13331 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

[New Thread 0x7fffde478700 (LWP 31114)]
[New Thread 0x7fffddc77700 (LWP 31115)]
[New Thread 0x7fffdd1a9700 (LWP 31116)]
[New Thread 0x7fffccea0700 (LWP 31117)]
[New Thread 0x7fffc7fff700 (LWP 31119)]
[New Thread 0x7fffbca45700 (LWP 31120)]
[New Thread 0x7fffbc244700 (LWP 31121)]
[Thread 0x7fffccea0700 (LWP 31117) exited]
[New Thread 0x7fffccea0700 (LWP 31124)]
[New Thread 0x7fff75ca8700 (LWP 31125)]
[New Thread 0x7fff74ced700 (LWP 31126)]
[New Thread 0x7fff6f436700 (LWP 31128)]
[New Thread 0x7fff6ec35700 (LWP 31129)]
[New Thread 0x7fff6e434700 (LWP 31130)]
[New Thread 0x7fff58d7e700 (LWP 31131)]
[New Thread 0x7fff5897d700 (LWP 31132)]
[New Thread 0x7fff5857c700 (LWP 31133)]
[Thread 0x7fffc7fff700 (LWP 31119) exited]
[Thread 0x7fff6f436700 (LWP 31128) exited]
FreeCAD: /build/freecad-daily-HVw0eJ/freecad-daily-0.17~alpha1+git201802241852~ubuntu16.04.1/src/Mod/Spreadsheet/App/PropertySheet.cpp:381: const Spreadsheet::Cell* Spreadsheet::PropertySheet::cellAt(App::CellAddress) const: Assertion `i != data.end()' failed.

Thread 1 "FreeCAD" received signal SIGABRT, Aborted.
0x00007ffff46e7428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
54	../sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0  0x00007ffff46e7428 in __GI_raise (sig=sig@entry=6)
    at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007ffff46e902a in __GI_abort () at abort.c:89
#2  0x00007ffff46dfbd7 in __assert_fail_base (fmt=<optimized out>, 
    assertion=assertion@entry=0x7fff6d3dee16 "i != data.end()", 
    file=file@entry=0x7fff6d3df0a0 "/build/freecad-daily-HVw0eJ/freecad-daily-0.17~alpha1+git201802241852~ubuntu16.04.1/src/Mod/Spreadsheet/App/PropertySheet.cpp", line=line@entry=381, 
    function=function@entry=0x7fff6d3df8a0 "const Spreadsheet::Cell* Spreadsheet::PropertySheet::cellAt(App::CellAddress) const") at assert.c:92
#3  0x00007ffff46dfc82 in __GI___assert_fail (
    assertion=0x7fff6d3dee16 "i != data.end()", 
    file=0x7fff6d3df0a0 "/build/freecad-daily-HVw0eJ/freecad-daily-0.17~alpha1+git201802241852~ubuntu16.04.1/src/Mod/Spreadsheet/App/PropertySheet.cpp", 
    line=381, 
    function=0x7fff6d3df8a0 "const Spreadsheet::Cell* Spreadsheet::PropertySheet::cellAt(App::CellAddress) const") at assert.c:101
#4  0x00007fff6d3a8fc0 in Spreadsheet::PropertySheet::cellAt(App::CellAddress) const () from /usr/lib/freecad-daily/lib/Spreadsheet.so
#5  0x00007fff6d3a8ff7 in Spreadsheet::PropertySheet::getSpans(App::CellAddress, int&, int&) const () from /usr/lib/freecad-daily/lib/Spreadsheet.so
#6  0x00007fff6d10eb49 in SpreadsheetGui::SheetTableView::updateCellSpan(App::CellAddress) () from /usr/lib/freecad-daily/lib/SpreadsheetGui.so
---Type <return> to continue, or q <return> to quit---

Spredsheet_1X_9PTS-Grouped_Cuts.fcstd (32,952 bytes)
FC_0.17_SS_Crash_1.png (141,150 bytes)
FC_0.17_SS_Crash_1.png (141,150 bytes)
FC_0.17_SS_Crash_2.png (90,111 bytes)
FC_0.17_SS_Crash_2.png (90,111 bytes)

wmayer

2018-03-25 11:40

administrator   ~0011056

https://github.com/FreeCAD/FreeCAD/commit/f485a0786f238b1c555b2dc8a5d511d5cf8c3e24

eivindkvedalen

2018-03-25 18:26

developer   ~0011057

This is still unresolved, I think. I registered this as another (3390), but later found out that it was already here.

Kunda1

2018-06-26 00:11

administrator   ~0011472

Assigning to eivindkvedalen since 0003390 was opened and assigned to you.

Kunda1

2018-07-31 22:59

administrator   ~0011570

https://github.com/FreeCAD/FreeCAD/commit/d2f9ab6a111975fce69c7f29bf3b7ecb8673a2db

Issue History

Date Modified Username Field Change
2018-03-02 01:09 3DME New Issue
2018-03-02 01:09 3DME File Added: FreeCad_Debug_Terminal_text.txt
2018-03-02 01:09 3DME File Added: Spredsheet_1X_9PTS-Grouped_Cuts.fcstd
2018-03-02 01:09 3DME File Added: FC_0.17_SS_Crash_1.png
2018-03-02 01:09 3DME File Added: FC_0.17_SS_Crash_2.png
2018-03-03 10:28 Kunda1 Project FreeCAD => Expressions
2018-03-03 10:29 Kunda1 Status new => confirmed
2018-03-24 08:41 eivindkvedalen Assigned To => eivindkvedalen
2018-03-24 08:41 eivindkvedalen Status confirmed => assigned
2018-03-24 08:44 eivindkvedalen Relationship added has duplicate 0003390
2018-03-25 11:40 wmayer Status assigned => closed
2018-03-25 11:40 wmayer Resolution open => fixed
2018-03-25 11:40 wmayer Fixed in Version => 0.17
2018-03-25 11:40 wmayer Note Added: 0011056
2018-03-25 18:26 eivindkvedalen Status closed => feedback
2018-03-25 18:26 eivindkvedalen Resolution fixed => reopened
2018-03-25 18:26 eivindkvedalen Note Added: 0011057
2018-06-26 00:10 Kunda1 Target Version => 0.18
2018-06-26 00:10 Kunda1 Description Updated View Revisions
2018-06-26 00:11 Kunda1 Status feedback => assigned
2018-06-26 00:11 Kunda1 Note Added: 0011472
2018-06-26 00:12 Kunda1 Fixed in Version 0.17 =>
2018-07-31 22:59 Kunda1 Status assigned => closed
2018-07-31 22:59 Kunda1 Fixed in Version => 0.18
2018-07-31 22:59 Kunda1 Note Added: 0011570