View Issue Details

IDProjectCategoryView StatusLast Update
0003360Path[FreeCAD] Bugpublic2018-11-04 22:29
ReporterJoshM Assigned Tomlampert  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS Version10
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0003360: PathWB Dressups move the parent operation to the bottom of the Job-Workflow.
DescriptionAny Path Workbench dressup moves the parent Operation to the bottom of the Job workflow list. This is problematic because it is confusing to the user, if they catch it.
Steps To ReproduceAdd any dressup to an existing Operation in Path workbench
Additional InformationI ran this by sliptonic in forums at: https://forum.freecadweb.org/viewtopic.php?f=15&t=27223#p217884


OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13344 (Git)
Build type: Release
Branch: master
Hash: 404452d6ee925b9c5504b58b65c7934e411bbe62
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.
FreeCAD Information

Activities

mlampert

2018-07-30 15:08

developer   ~0011567

I'm tempted to close this issue because it is working as designed. Any operation that is being created is added at the bottom, dressups are no exception.

JoshM

2018-07-30 15:22

reporter   ~0011568

That's the frustrating part. It is consistent, but it makes use more challenging.

Kunda1

2018-08-23 16:59

administrator   ~0011641

FYI sliptonic thinks this is a valid issue.

+ Fixed forum link in the ticket summary since it was pointing to the wrong forum thread.

wmayer

2018-11-04 22:29

administrator   ~0012132

https://github.com/FreeCAD/FreeCAD/commit/bfcd21361fe431dd96856fc3ddd934e537ec30c8
https://github.com/FreeCAD/FreeCAD/commit/fe8677fab1b169ca9421662f63478794423de87f

Issue History

Date Modified Username Field Change
2018-03-01 19:08 JoshM New Issue
2018-05-31 17:34 Kunda1 Project FreeCAD => Path
2018-07-30 15:08 mlampert Note Added: 0011567
2018-07-30 15:22 JoshM Note Added: 0011568
2018-08-23 16:55 Kunda1 Additional Information Updated View Revisions
2018-08-23 16:59 Kunda1 Note Added: 0011641
2018-11-03 23:26 mlampert Assigned To => mlampert
2018-11-03 23:26 mlampert Status new => assigned
2018-11-04 22:29 wmayer Status assigned => closed
2018-11-04 22:29 wmayer Resolution open => fixed
2018-11-04 22:29 wmayer Fixed in Version => 0.18
2018-11-04 22:29 wmayer Note Added: 0012132