View Issue Details

IDProjectCategoryView StatusLast Update
0003298SketcherBugpublic2018-01-13 12:06
Reporterchrisb Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.18Fixed in Version0.17 
Summary0003298: Validate sketch tool reports false positives on tangent constraints
DescriptionThe Tool Menu->PartDesign->Validate sketch reports missing coincidences if the tangent constraint is used on the endpoints only.
It should be the other way round: If points are coincident and have a tangent constraint the redundant and often problematic coincidence should be reported.

I tried to reproduce the issue with the most simple sketch of a line plus attached arc, but in that case the missing coincidence wasn't reported.
Steps To ReproduceSee forum discussion
Additional InformationOS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12915 (Git)
Build type: Release
Branch: (HEAD detached at 90a71f3)
Hash: 90a71f34bc448d1396d2e27f4177885897199152
Python version: 2.7.14
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: German/Germany (de_DE)
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0003299 closedabdullah Sketcher should check redundant coincidences used with tangent constraints 

Activities

chrisb

2018-01-03 18:12

developer  

validateSketchFalsePositive.FCStd (3,933 bytes)

abdullah

2018-01-08 07:29

manager   ~0010728

This reports 2 non-coincidents

The apparently problematic one is the one on the ellipse arc endpoint to the right, where the coincident and tangency are.

What FC is trying to notify the end-user is that at that point there are more vertices than the ones that the number of vertex-constraining constraints can fix in place. Let's check:

There is a coincidence arc endpoint to line endpoint, which removes the potential coincidence between the arc and the line.

However, at that same point, there is the endpoint of the major axis of the elliptical arc. This point is geometrically coincident with those other vertices. However, there is no (external) constraint forcing a coincidence. So what FC is notifying is: "hey! take care, you have points apparently on the same spot but I can not detect anything forcing them to stay there".

Now, you can argue: "Ok, but this major axis issue is going to drive everybody crazy". I think you are right, but my question would be: "Do we have a situation where we would like this to be detected?". Maybe the one attached is one far-fetched example. There I intentionally did not make a coincidence constraint between the two construction lines.

I think it is not a bug, but it is indeed annoying. I think we need a solution for it. Maybe marking non-coincidence of construction geometry with a different colour?

You will come with something better...

val2-detection.png (2,151 bytes)
val2-detection.png (2,151 bytes)
val2.png (12,873 bytes)
val2.png (12,873 bytes)

abdullah

2018-01-11 09:55

manager   ~0010736

https://github.com/FreeCAD/FreeCAD/pull/1216

wmayer

2018-01-13 12:06

administrator   ~0010752

https://github.com/FreeCAD/FreeCAD/commit/10c0af4a8af76450c57ac21bae050cb52b0f307d
https://github.com/FreeCAD/FreeCAD/commit/0d21e94d3fbfbd99c83ecd2cae9f1f151a5e455e

Issue History

Date Modified Username Field Change
2018-01-03 18:12 chrisb New Issue
2018-01-03 18:12 chrisb Status new => assigned
2018-01-03 18:12 chrisb Assigned To => abdullah
2018-01-03 18:12 chrisb File Added: validateSketchFalsePositive.FCStd
2018-01-03 20:34 Kunda1 Relationship added related to 0003299
2018-01-08 07:29 abdullah File Added: val2-detection.png
2018-01-08 07:29 abdullah File Added: val2.png
2018-01-08 07:29 abdullah Note Added: 0010728
2018-01-11 09:55 abdullah Note Added: 0010736
2018-01-13 12:06 wmayer Status assigned => closed
2018-01-13 12:06 wmayer Resolution open => fixed
2018-01-13 12:06 wmayer Fixed in Version => 0.17
2018-01-13 12:06 wmayer Note Added: 0010752