View Issue Details

IDProjectCategoryView StatusLast Update
0003260Path[FreeCAD] Bugpublic2017-11-26 17:40
ReporterberkaAssigned Towmayer 
PriorityhighSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformIntel x86_64OSMacOSOS Version10.12.6 (16G29)
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0003260: Double Quote in tool name is not escaped in FCStd file
DescriptionI've been using 0.17 for path generation only. I repeatedly had unexpected behavior with one of the tools. I had named it '5/64" drill'. There may be more issues, but at least one is the lack of escaping of the tool name when the file is saved. The offending line in the document.xml file looks like this:
                <Property name="Tool" type="Path::PropertyTool" group="Base" 
doc="The tool used by this controller" attr="0" ro="0" hide="0">
                    
<Tool name="5_64" drill" diameter="1.984375000000" length="0.000000000000" 
flat="0.000000000000" corner="0.000000000000" angle="135.000000000000" 
height="17.000000000000" type="EndMill" mat="HighSpeedSteel" />     
                
</Property>


In this experiment, I had removed the "/" character, but still had trouble saving/opening because of the double-quote '"'

The corrupted file as a result of the experiment is attached.

When opening this file, I get this error message:
FreeCAD wrote

Fatal Error at file /Users/berka/Documents/QCM/Design - Mechanical/Plate12x/Rev02/DrillTest4.FCStd, line 851, char 44
Invalid Document.xml: equal sign expected
Error in T5: 5_64" drill: Property not found

This is not the only symptom...
Steps To Reproduce- Create a tool with a name containing a double-quote.
- In a Job setup, add a tool controller using this tool.
- Save the file.
- Close the file
- Reopen the saved file.
- Browse to the job and and attempt to edit its tools.
Additional InformationOS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12579 (Git)
Build type: Release
Branch: (HEAD detached at 03f439c)
Hash: 03f439caf7e21a510f31ad471af1f1aec20f7d96
Python version: 2.7.14
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
TagsPath, units

Relationships

has duplicate 0003261 closedmlampert Path Job Operations cannot be edited after save and reload 

Activities

berka

2017-11-13 04:30

reporter  

DrillTest4.FCStd (27,111 bytes)

Kunda1

2017-11-13 23:38

administrator   ~0010414

@berka thanks for the ticket. BTW, did you not see the yellow banner at the top of the tracker page about opening up a forum thread first? If not, look again.

@mlampert care to weigh in?

berka

2017-11-14 01:20

reporter   ~0010415

Yup; saw the banner. I didn't think any pre-discussion is needed. This is a pretty clear bug, and it's on the latest 0.17. (I did search to see if it had been discussed already.)

Kunda1

2017-11-14 08:26

administrator   ~0010416

@berka thanks again.

Kunda1

2017-11-19 15:32

administrator   ~0010428

0003261 was a dupe of this issue

llamas

2017-11-20 19:07

reporter   ~0010443

I'm the one that filed the duplicate issue. It looks like it presented a little differently for me, but it looks like the root cause is definitely the same. I confirmed that removing the inches " symbol from the tool name resulted in a file that saved without issue, where leaving the " in place result in a file that is corrupted when reloaded.

berka

2017-11-21 10:39

reporter   ~0010450

llamas wrote

it presented a little differently for me

@llamas, I had general "unexpected behavior" I couldn't sufficiently capture here. Once I found this cause, I dropped looking for any other cause or characterizing it more. I hope this helps.
On a lighter note, this reminds me of little Bobby Tables.
Cheers to the developers and keep up the good work!

wmayer

2017-11-26 17:40

administrator   ~0010474

https://github.com/FreeCAD/FreeCAD/commit/32510bde83edb9a40deb6ffb7b09d71eea933351

Issue History

Date Modified Username Field Change
2017-11-13 04:30 berka New Issue
2017-11-13 04:30 berka File Added: DrillTest4.FCStd
2017-11-13 04:30 berka Tag Attached: Path
2017-11-13 23:38 Kunda1 Note Added: 0010414
2017-11-14 01:20 berka Note Added: 0010415
2017-11-14 08:26 Kunda1 Note Added: 0010416
2017-11-18 03:36 mlampert Relationship added has duplicate 0003261
2017-11-19 15:32 Kunda1 Note Added: 0010428
2017-11-20 13:28 wmayer Priority normal => high
2017-11-20 13:32 wmayer Target Version => 0.17
2017-11-20 19:07 llamas Note Added: 0010443
2017-11-21 01:43 Kunda1 Tag Attached: units
2017-11-21 01:43 Kunda1 Status new => confirmed
2017-11-21 10:39 berka Note Added: 0010450
2017-11-21 11:07 Kunda1 Severity major => block
2017-11-26 16:03 wmayer Project FreeCAD => Path
2017-11-26 17:40 wmayer Assigned To => wmayer
2017-11-26 17:40 wmayer Status confirmed => closed
2017-11-26 17:40 wmayer Resolution open => fixed
2017-11-26 17:40 wmayer Fixed in Version => 0.17
2017-11-26 17:40 wmayer Note Added: 0010474