View Issue Details

IDProjectCategoryView StatusLast Update
0000322FreeCADBugpublic2011-09-01 17:49
Reporterunauthenticated Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000322: View of Pad in Drawing looks weird
DescriptionFirst bug:
I sketch simple shape (3 lines + arc) and I used "Pad" from Part Design - screen 1. Next I try put view of this Pad in Drawing sheet. Result was weird - arc looked "mirrored" - screen 2.

Second bug:
Export to DXF has problems with FreeCAD logo (from drawing table). "Gear" is too huge. In the third screen you can see DXF from FreCAD opened in 2D CAD.
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0000264 closed Drawing View for fused cube+cylinder and cube+sphere not shown correctly 

Activities

2011-04-02 16:04

 

fcproblem.jpg (Attachment missing)

Jriegel

2011-04-02 16:25

administrator   ~0000766

Mhh, ok, but ..... ;)

The arc feature is brand new and not even fully implemented.

So I think we should wait with bug reports until the Sketcher
development is less paced then now.....

wmayer

2011-04-02 17:28

administrator   ~0000768

As far as Ican see this is not a bug in the sketcher. It's a bug in the SVG ouput for the drawing. This was already addressed in 0000264.

normandc

2011-04-02 17:48

manager   ~0000769

The second bug should get its own entry, since it's related to DXF export, while first one is related to SVG output.

unauthenticated

2011-07-30 21:13

viewer   ~0000959

First bug still exist. It looks like y coord is reversed. Arc is simply upside-down.

2011-08-30 12:44

 

alibre_bracket.svg (Attachment missing)

unauthenticated

2011-08-30 12:49

viewer   ~0001016

I've uploaded svg file alibre_bracket.svg with views of part http://forum.freecadweb.org/viewtopic.php?f=8&t=1222&start=0#p9387 There is adiidtional small issues: additional circles (view in right corner) and lines which should be hidden (bottom view).

kwahoo

2011-09-01 12:10

 

0000322.FCStd (Attachment missing)

wmayer

2011-09-01 17:49

administrator   ~0001031

Fixed in r4868

Issue History

Date Modified Username Field Change
2011-04-02 16:04 unauthenticated New Issue
2011-04-02 16:04 unauthenticated File Added: fcproblem.jpg
2011-04-02 16:25 Jriegel Note Added: 0000766
2011-04-02 17:28 wmayer Note Added: 0000768
2011-04-02 17:28 wmayer Relationship added duplicate of 0000264
2011-04-02 17:48 normandc Note Added: 0000769
2011-07-30 21:13 unauthenticated Note Added: 0000959
2011-08-30 12:44 unauthenticated File Added: alibre_bracket.svg
2011-08-30 12:49 unauthenticated Note Added: 0001016
2011-09-01 12:10 wmayer File Added: 0000322.FCStd
2011-09-01 17:49 wmayer Note Added: 0001031
2011-09-01 17:49 wmayer Status new => closed
2011-09-01 17:49 wmayer Resolution open => fixed
2011-09-01 17:49 wmayer Fixed in Version => 0.12