View Issue Details

IDProjectCategoryView StatusLast Update
0000320FreeCADFeaturepublic2011-09-17 12:57
ReporterpperisinAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000320: Allow extruding faces on parts
DescriptionThis might be uncommon function in other tools, but it would be nice to be able to extrude faces on parts. Right now I have to:
1. Copy part
2. Explode part
3. Delete all faces other than the one I want to extrude (it can take a while on complex parts)
4. extrude leftover face
5. Do union of first part and new part.

It would be nice to be able just to select a face and then click on extrude Icon on toolbar, and that would (in behind) hide current part, create new one with extruded face. After that in the option of the new part you could change extrude value and normal.

Maybe this request does not make sense. What do you think

Regards,
Petar Perisin
TagsNo tags attached.

Activities

unauthenticated

2011-03-29 15:31

viewer   ~0000751

Last edited: 2011-03-29 15:31

That would be perfect! Was just looking for something like that.

rolbit

yorik

2011-04-24 13:37

administrator   ~0000799

I just extended the Draft Trimex tool so it works when you select a single face of an object. It produces a new object, which must be joined to the original one if wanted.

pperisin

2011-05-02 09:45

reporter   ~0000808

Hi Yorik

I just wanted to say thank you, and this works PERFECT. You just select one face and start Trimm, and if you want to have extrusion 90° to face, just hold SHIFT.

Although, it wold be much more User Frendly if it was under PAD toolbar item, and that PAD object was created, so that you can modify pad height later on, but still this is very good.

Thanx

yorik

2011-05-02 11:50

administrator   ~0000809

Good idea, the extrusion could become a pad object, or a pocket if the extrusion goes opposite to the face normal. I'll try to do that when i have a sec. I'll also try to adapt the generic extrude dialog to allow extruding single faces.

The pad tool itself is made to work with a 2D object, I'm not sure how practical it would be to make it extrude faces...

pperisin

2011-05-02 17:14

reporter   ~0000810

I started new thread about this, since I think that this might start discussion. I have also purposed some further suggestions about this.

http://forum.freecadweb.org/viewtopic.php?f=8&t=964

so have a look

Regards,
Petar Perisin

yorik

2011-09-17 12:57

administrator   ~0001116

I think the pad question took another direction, so this particular issue can be considered as done, since the Draft trim command does what is asked.

Issue History

Date Modified Username Field Change
2011-03-27 09:32 pperisin New Issue
2011-03-29 15:31 unauthenticated Note Added: 0000751
2011-03-29 15:31 unauthenticated Note Edited: 0000751
2011-04-24 13:37 yorik Note Added: 0000799
2011-05-02 09:45 pperisin Note Added: 0000808
2011-05-02 11:50 yorik Note Added: 0000809
2011-05-02 11:50 yorik Status new => assigned
2011-05-02 11:50 yorik Assigned To => yorik
2011-05-02 17:14 pperisin Note Added: 0000810
2011-09-17 12:57 yorik Note Added: 0001116
2011-09-17 12:57 yorik Status assigned => closed
2011-09-17 12:57 yorik Resolution open => fixed
2011-09-17 12:57 yorik Fixed in Version => 0.12