View Issue Details

IDProjectCategoryView StatusLast Update
0000032FreeCADBugpublic2009-11-27 08:12
Reporterwmayer Assigned Toyorik  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS Version
Product Version 
Target VersionFixed in Version0.9 
Summary0000032: Draft tools don't work anymore
DescriptionWhen using any command of the Draft toolbar there is an error message:

Running the Python command 'Draft_Line' failed:
Traceback (most recent call last):
  File "C:\Projekte\FreeCAD9\build\Mod\Draft\Draft.py", line 861, in Activated
    self.ui.translate("Pick first point:\n")

'Ui_draftToolbar' object has no attribute 'translate'

And when trying to use a command in case there is now document open:
Running the Python command 'Draft_Line' failed:
Traceback (most recent call last):
  File "C:\Projekte\FreeCAD9\build\Mod\Draft\Draft.py", line 854, in Activated
    Creator.Activated(self)
  File "C:\Projekte\FreeCAD9\build\Mod\Draft\Draft.py", line 809, in Activated
    if not self.doc: self.finish()
  File "C:\Projekte\FreeCAD9\build\Mod\Draft\Draft.py", line 874, in finish
    Creator.finish(self)
  File "C:\Projekte\FreeCAD9\build\Mod\Draft\Draft.py", line 837, in finish
    self.ui.translate("")

'Ui_draftToolbar' object has no attribute 'translate'
Steps To Reproduce1. Load Draft workbench
2. Create a new document (or not)
3. Press on one of the toolbar buttons
TagsNo tags attached.
FreeCAD Information

Activities

yorik

2009-11-04 18:42

administrator   ~0000023

Oops, forgot to change a file... fixed in r2607

yorik

2009-11-04 18:43

administrator   ~0000024

fixed in r2607

wmayer

2009-11-04 21:59

administrator   ~0000026

The one error is fixed now. But you still get an error message when trying to use a command if *no* 3d view is open.

yorik

2009-11-05 01:10

administrator   ~0000027

Funny, I thought I had solved that before... Anyway, I fixed it in r2608. I'd better keep this open until we make sure no more things happen...

wmayer

2009-11-27 08:12

administrator   ~0000041

It seems to be really fixed. Thus, I close it again.

Issue History

Date Modified Username Field Change
2009-11-04 18:32 wmayer New Issue
2009-11-04 18:32 wmayer Status new => assigned
2009-11-04 18:32 wmayer Assigned To => yorik
2009-11-04 18:42 yorik Note Added: 0000023
2009-11-04 18:43 yorik Note Added: 0000024
2009-11-04 18:43 yorik Status assigned => resolved
2009-11-04 18:43 yorik Fixed in Version => 0.9
2009-11-04 18:43 yorik Resolution open => fixed
2009-11-04 21:59 wmayer Note Added: 0000026
2009-11-04 21:59 wmayer Status resolved => feedback
2009-11-04 21:59 wmayer Resolution fixed => reopened
2009-11-05 01:10 yorik Note Added: 0000027
2009-11-27 08:12 wmayer Note Added: 0000041
2009-11-27 08:12 wmayer Status feedback => closed
2009-11-27 08:12 wmayer Resolution reopened => fixed