View Issue Details

IDProjectCategoryView StatusLast Update
0003178FreeCADFeaturepublic2017-09-21 02:22
ReporterplgarciaAssigned Topeterl94 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003178: Super Placement should be shown only when relevant in the Property Panel
DescriptionThe super placement appears always in the properties panel, even for object where the super placement is non-relevant. It should only be shown when super placement is relevant.

It is also possible to modify the super placement. For example by select the position then X and click on up or down arrow. But only once after these arrows are greyed.
It is also possible to modify the super placement in python console :
FreeCAD.getDocument("Extruder5C3m3").getObject("Cylinder019").superPlacement 
= App.Placement(App.Vector(5,0,0),App.Rotation(App.Vector(0,0,1),0))


All the changes have no effect because not applicable to a cylinder in my case.

I think the super placement properties should only be shown when super placement makes sense, and the command line should report an error.
Steps To ReproduceJust create a cylinder and view data properties in the properties pannel.
TagsNo tags attached.

Activities

plgarcia

2017-09-07 09:23

reporter   ~0010080

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11967 (Git)
Build type: Release
Branch: master
Hash: d0c5865f323aa9555662912f2ff96188f29096a6
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: French/France (fr_FR)

CaptureSuperPlacement.JPG (125,436 bytes)
CaptureSuperPlacement.JPG (125,436 bytes)

Kunda1

2017-09-07 13:36

administrator   ~0010082

@plgarcia Thanks for the report. Please also open a forum thread in conjunction with this ticket and link them both to each other. Thanks!

plgarcia

2017-09-07 15:35

reporter   ~0010084

here is the post where we discussed that.
https://forum.freecadweb.org/viewtopic.php?f=3&t=23564
regards

Kunda1

2017-09-07 18:31

administrator   ~0010086

Changed to Feature, edited bug summary and title.

peterl94

2017-09-21 02:22

developer   ~0010140

@plgarcia I'm closing this because I believe commit 7647495 sufficiently meets this request.

Issue History

Date Modified Username Field Change
2017-09-07 09:16 plgarcia New Issue
2017-09-07 09:23 plgarcia File Added: CaptureSuperPlacement.JPG
2017-09-07 09:23 plgarcia Note Added: 0010080
2017-09-07 13:35 Kunda1 Tag Attached: #post-to-forum
2017-09-07 13:36 Kunda1 Note Added: 0010082
2017-09-07 13:37 Kunda1 Status new => feedback
2017-09-07 15:33 plgarcia Tag Attached: https://forum.freecadweb.org/viewtopic.php?f=3&t=23564
2017-09-07 15:34 plgarcia Tag Detached: https://forum.freecadweb.org/viewtopic.php?f=3&t=23564
2017-09-07 15:35 plgarcia Note Added: 0010084
2017-09-07 15:35 plgarcia Status feedback => new
2017-09-07 15:36 plgarcia Tag Attached: https://forum.freecadweb.org/viewtopic.php?f=3&t=23564
2017-09-07 18:27 Kunda1 Tag Detached: https://forum.freecadweb.org/viewtopic.php?f=3&t=23564
2017-09-07 18:28 Kunda1 Tag Detached: #post-to-forum
2017-09-07 18:31 Kunda1 Category Bug => Feature
2017-09-07 18:31 Kunda1 Summary Edition of super placement => Super Placement should be shown only when relevant in the Property Panel
2017-09-07 18:31 Kunda1 Description Updated View Revisions
2017-09-07 18:31 Kunda1 Note Added: 0010086
2017-09-21 02:20 peterl94 Assigned To => peterl94
2017-09-21 02:20 peterl94 Status new => assigned
2017-09-21 02:22 peterl94 Status assigned => closed
2017-09-21 02:22 peterl94 Resolution open => fixed
2017-09-21 02:22 peterl94 Fixed in Version => 0.17
2017-09-21 02:22 peterl94 Note Added: 0010140