View Issue Details

IDProjectCategoryView StatusLast Update
0003169FreeCADBugpublic2017-10-17 17:15
Reporteryclee126Assigned Towmayer 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target Version0.17Fixed in Version0.17 
Summary0003169: Mesh Design WB tools does not work on translated object
DescriptionIn Mesh Design workbench, the mesh cut tool(Cuts a mesh with a picked polygon) and some others does not works on object which has placement value, it acts like if the object is not translated.
The following example is for mesh cut tool, also I've found same error in Curvature plot tool and Split mesh tool.(I couldn't test error for other tools, sorry)

Edit: Forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=24073
Steps To Reproduce1.Create a new document
2.Set to top view(2)
3.Go to Mesh Design WB
4.Meshes > Regular soild > Create a 10x10x10mm cube
5.Select the cube > placement (...) > type 10mm for x coordinate > OK
6.Select the cube, execute the mesh cut tool
7.select right-bottom part of the cube with triangle shape > inner
8.The cube does not being cut
9.Do step 6
10.Do step 7, but select it like if the cube does not translated
11.The cube being cut.

Additional InformationOS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsMesh

Activities

Kunda1

2017-08-28 14:16

administrator   ~0010019

@chrisb care to weigh in ?
@yclee126 FYI please open a forum thread before you open a ticket to confirm that this is a valid bug especially since you are reporting a 0.16 bug and over 5K commits have been made to 0.17dev.

yclee126

2017-08-28 16:02

reporter   ~0010024

@Kunda1 Sorry for not posting a topic in forum first, I'll remember this for not happening again.
Later I posted the topic in forum, but no one tested it on the newest 0.17 dev version.
So I've downloaded the newest 0.17 dev version, and the bug occurred as same.
A quick proof video is uploaded here, I recorded it on my laptop, please ignore flaccid cursor movement.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11919 (Git)
Build type: Release
Branch: master
Hash: fccb5dbc87b919164610296adc96aa8b4fe4825e
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: Korean/RepublicOfKorea (ko_KR)

Kunda1

2017-08-28 16:07

administrator   ~0010025

Last edited: 2017-08-28 16:07

View 2 revisions

yclee126 wrote

Later I posted the topic in forum, but no one tested it on the newest 0.17 dev version.

@yclee126 if you posted to the forum, please link to this ticket and vice-a-versa
Thanks! Also thanks for your detailed bug report especially re-testing on 0.17. We appreciate the effort!

chrisb

2017-08-29 06:52

developer   ~0010038

I am sorry, but I have no experience with meshes.

yclee126

2017-08-29 15:01

reporter   ~0010040

Last edited: 2017-08-29 15:05

View 2 revisions

@Kunda1 link to the post : here
@chrisb What's the problem? Just make your experience now!

Kunda1

2017-08-29 17:36

administrator   ~0010041

Confirmed by @bejant on the forum thread

Kunda1

2017-10-10 19:04

administrator   ~0010284

Added forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=24073

wmayer

2017-10-16 18:15

administrator   ~0010302

Last edited: 2017-10-17 17:15

View 2 revisions

https://github.com/FreeCAD/FreeCAD/commit/9c2528a982eb10a5cd15af738b72d63de44d60f6
https://github.com/FreeCAD/FreeCAD/commit/3bd425df26e5a3a973928c69644c162c0a25bc49

Issue History

Date Modified Username Field Change
2017-08-27 03:21 yclee126 New Issue
2017-08-27 03:21 yclee126 Tag Attached: Mesh
2017-08-28 14:16 Kunda1 Note Added: 0010019
2017-08-28 16:02 yclee126 Note Added: 0010024
2017-08-28 16:07 Kunda1 Note Added: 0010025
2017-08-28 16:07 Kunda1 Note Edited: 0010025 View Revisions
2017-08-29 06:52 chrisb Note Added: 0010038
2017-08-29 15:01 yclee126 Note Added: 0010040
2017-08-29 15:05 yclee126 Note Edited: 0010040 View Revisions
2017-08-29 17:36 Kunda1 Status new => confirmed
2017-08-29 17:36 Kunda1 Note Added: 0010041
2017-08-29 17:38 Kunda1 Target Version => 0.17
2017-10-10 19:04 Kunda1 Description Updated View Revisions
2017-10-10 19:04 Kunda1 Note Added: 0010284
2017-10-16 18:15 wmayer Assigned To => wmayer
2017-10-16 18:15 wmayer Status confirmed => closed
2017-10-16 18:15 wmayer Resolution open => fixed
2017-10-16 18:15 wmayer Fixed in Version => 0.17
2017-10-16 18:15 wmayer Note Added: 0010302
2017-10-17 17:15 wmayer Note Edited: 0010302 View Revisions