View Issue Details

IDProjectCategoryView StatusLast Update
0003168Path[FreeCAD] Bugpublic2017-10-07 23:33
ReportermarcAssigned Tomlampert 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSMac OSOS Version10.12.5
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0003168: Path >Pocket > Predictably ignores some Pockets
DescriptionThe Path > Pocket function has trouble detecting only certain letter of the alphabet that are cut into a piece.
Steps To ReproduceMake a Cube.
Add to a Part File
Select a surface
Select "Draft" > (S,S) ShapeString
type the alphabet
add the "avenir.tff" font
Select "Part Design" > cut to a depth of 10 thou
set the default tool to an engraver, cutting diameter=5 thou, cutting angle 45 Deg
select the floor of each letter
Select the Path > "pocket"
select any "pattern"
Certain letters will be left out as if the slot is too small even though it is clear there is enough room for the cutter to reach
TagsNo tags attached.

Activities

marc

2017-08-26 20:52

reporter  

Avenir-Roman.ttf (101,228 bytes)

Kunda1

2017-08-28 19:38

administrator   ~0010032

@sliptonic please weigh in
@marc thanks for the report. Please read https://freecadweb.org/wiki/Tracker to familiarize yourself with how to post bugs/features. Thanks

marc

2017-09-05 06:45

reporter   ~0010068

Any update on this? It appears the algorithm doesn't play nice with little tools like my engraver.

Kunda1

2017-09-05 19:47

administrator   ~0010069

@marc again please read tracker guidelines. You need to add your full FC info (Help > About FreeCAD > Copy to clipboard) also it is customary to let the devs know on the forum first. That's how you get more publicity about issues.

CC @mlampert care to weigh in?

mlampert

2017-09-05 20:16

developer   ~0010070

I'm afraid this is a known issue with no solution as of today (https://forum.freecadweb.org/viewtopic.php?f=15&t=23492). OCC just released a new version and we still have to see how it'll behave.

In order to reproduce, can you attach your FC file please and your full version info (see Kunda1's comment above on how to get that)?

mlampert

2017-09-07 20:58

developer   ~0010089

I've compiled FC with the latest version of OCC (7.2) and the issue seems to be resolved - however I cannot verify/test without having the actual file.

mlampert

2017-10-07 23:33

developer   ~0010260

Fixed by new pocketing operation https://github.com/FreeCAD/FreeCAD/pull/1004

Issue History

Date Modified Username Field Change
2017-08-26 20:52 marc New Issue
2017-08-26 20:52 marc File Added: Screen Shot 2017-08-26 at 1.28.30 PM.png
2017-08-26 20:52 marc File Added: Avenir-Roman.ttf
2017-08-28 19:38 Kunda1 Note Added: 0010032
2017-09-05 06:45 marc Note Added: 0010068
2017-09-05 19:47 Kunda1 Note Added: 0010069
2017-09-05 20:16 mlampert Note Added: 0010070
2017-09-06 02:54 Kunda1 Status new => feedback
2017-09-07 20:58 mlampert Note Added: 0010089
2017-10-07 23:32 mlampert Assigned To => mlampert
2017-10-07 23:32 mlampert Status feedback => assigned
2017-10-07 23:33 mlampert Status assigned => closed
2017-10-07 23:33 mlampert Resolution open => fixed
2017-10-07 23:33 mlampert Fixed in Version => 0.17
2017-10-07 23:33 mlampert Note Added: 0010260