View Issue Details

IDProjectCategoryView StatusLast Update
0003160SketcherBugpublic2017-08-18 10:39
ReporterSam Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformi7 laptopOSUbuntuOS Version16.04.3
Product Version0.17 
Target VersionFixed in Version 
Summary0003160: New octagon collapses
DescriptionInserting an octagon in sketcher behaves unexpectedly when the centre is on the origin and the radius is placed on the X axis; it is created with zero size. Subsequently trying to set the radius of the circumscribing circle is not allowed; conflicting constraints.

After some experimenting, it seems to only happen when the suggested constraints are point on object, and horizontal.

Forum thread: Octagon Fail

Possibly related issue: 0000909
Steps To ReproduceStart FreeCAD
New document
Part Design WB
New sketch on XY plane
(Auto constraints on)
Create Octagon
Centre on origin
Radius on horizontal axis; x > 0 y = 0
(the suggested constraints are horizontal and point on object)
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0003154 closedabdullah sketch disappears when inserting polygon with multiple autoconstraints 

Activities

Sam

2017-08-15 09:35

reporter   ~0009938

Crapola. Duplicate of issue 0003154

Sorry for the noise.

Kunda1

2017-08-18 10:39

administrator   ~0009949

Closing as is dupe of 0003154

Issue History

Date Modified Username Field Change
2017-08-15 09:31 Sam New Issue
2017-08-15 09:35 Sam Note Added: 0009938
2017-08-15 12:42 wmayer Relationship added related to 0003154
2017-08-18 10:38 Kunda1 Relationship replaced duplicate of 0003154
2017-08-18 10:39 Kunda1 Status new => closed
2017-08-18 10:39 Kunda1 Resolution open => duplicate
2017-08-18 10:39 Kunda1 Note Added: 0009949