View Issue Details

IDProjectCategoryView StatusLast Update
0003154SketcherBugpublic2017-12-07 10:08
Reporterurban.novakAssigned Toabdullah 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003154: sketch disappears when inserting polygon with multiple autoconstraints
DescriptionInserting polygon with two auto constraints doesn't work as expected. Inserted polygon immediately disappears.

Workaround: either use at most one auto constraint
         or press Undo (Ctrl Z) , this removes the second auto constraint and polygon appears again.
Steps To Reproduce1. Open new document, switch to Sketcher workbench, create new sketch
2. insert regular polygon for example hexagon
      with center auto constrained to (0,0)
      and one of edge points auto constrained to one of axes
Additional InformationBug can be reproduced in both 0.16 and 0.17

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6706 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: f86a4e411ff7848dea98d7242f43b7774bee8fa0
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11749 (Git)
Build type: Release
Branch: master
Hash: 6c4bdf24dfd697ee212ec5950969125851a0907c
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

TagsNo tags attached.

Relationships

related to 0000909 closedlogari81 Disappearing sketches due to tangency autoconstraint 
has duplicate 0003160 closed New octagon collapses 

Activities

urban.novak

2017-08-10 14:51

reporter   ~0009885

Issue can be reproduced in latest 0.16 backport release as well.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6712 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: da2d364457257a7a8c6fb2137cea12c45becd71a
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-08-18 10:39

administrator   ~0009948

Seems that 0003160 is a duplicate of this ticket.

Kunda1

2017-08-18 10:40

administrator   ~0009950

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=3&t=23899

abdullah

2017-12-06 16:07

manager   ~0010519

https://github.com/FreeCAD/FreeCAD/pull/1141

wmayer

2017-12-07 10:08

administrator   ~0010537

https://github.com/FreeCAD/FreeCAD/commit/2e1d219377720bb2658f9120ee474aab43d77973

Issue History

Date Modified Username Field Change
2017-08-10 14:41 urban.novak New Issue
2017-08-10 14:51 urban.novak Note Added: 0009885
2017-08-15 12:42 wmayer Relationship added related to 0003160
2017-08-18 10:38 Kunda1 Relationship replaced has duplicate 0003160
2017-08-18 10:39 Kunda1 Note Added: 0009948
2017-08-18 10:40 Kunda1 Note Added: 0009950
2017-08-18 10:40 Kunda1 Status new => confirmed
2017-08-18 10:41 Kunda1 Priority normal => high
2017-08-18 10:41 Kunda1 Severity minor => major
2017-08-18 10:41 Kunda1 Target Version => 0.17
2017-09-27 12:22 Kunda1 Relationship added related to 0000909
2017-12-06 16:07 abdullah Note Added: 0010519
2017-12-07 04:57 abdullah Assigned To => abdullah
2017-12-07 04:57 abdullah Status confirmed => assigned
2017-12-07 10:08 wmayer Status assigned => closed
2017-12-07 10:08 wmayer Resolution open => fixed
2017-12-07 10:08 wmayer Fixed in Version => 0.17
2017-12-07 10:08 wmayer Note Added: 0010537