View Issue Details

IDProjectCategoryView StatusLast Update
0003152FreeCADBugpublic2017-09-25 09:31
ReportersedderzAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003152: FreeCAD crashes upon opening saved file
DescriptionFreeCAD crashes when opening a saved file. The last operation before saving was attempting to pad a sketch. No output on command line other than Segmentation Fault.
Steps To ReproduceOpen file.
Additional InformationOS: Ubuntu 16.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11740 (Git)/Daily-PPA
Build type: None
Branch: master
Hash: 6b05302c2e70f191a2a5787f55c5b549155b9824
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedKingdom (en_GB)

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=23966
Tagscrash

Relationships

related to 0002567 closedickby PartDesign Cyclic dependency of containers leads to crash 

Activities

sedderz

2017-08-09 00:43

reporter  

Parabolic trough.fcstd (20,143 bytes)

Kunda1

2017-08-09 21:00

administrator   ~0009884

@sedderz any chance you can invoke FreeCAD from the command line with a debugger and post the backtrace?
https://freecadweb.org/wiki/debugging

Kunda1

2017-08-14 00:44

administrator   ~0009926

@sedderz ping
CC @normandc

I can confirm Segfault on
OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11779 (Git)
Build type: None
Branch: master
Hash: 7c87549e4ba992cf324c59986908a22ccb5fcf4c
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)


I ran it through gdb but it wasn't useful since appimage doesn't have debug symbols:
warning: Could not load shared library symbols for ././/lib/freecad-daily/lib/Part.so.

Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for ././/lib/freecad-daily/lib/PartGui.so.
Do you need "set solib-search-path" or "set sysroot"?

Thread 1 "freecad-daily" received signal SIGSEGV, Segmentation fault.
0x00007ffff695f0c9 in ?? ()

Kunda1

2017-08-19 12:54

administrator   ~0009954

Stack trace by wmayer: https://forum.freecadweb.org/viewtopic.php?f=8&t=23966#p187315v

Kunda1

2017-08-19 13:39

administrator   ~0009956

According to DeepSOIC this issue is caused by 0002567

wmayer

2017-09-25 09:31

administrator   ~0010184

Fixed with PR 916

Issue History

Date Modified Username Field Change
2017-08-09 00:43 sedderz New Issue
2017-08-09 00:43 sedderz File Added: Parabolic trough.fcstd
2017-08-09 00:43 sedderz Tag Attached: crash
2017-08-09 21:00 Kunda1 Note Added: 0009884
2017-08-14 00:44 Kunda1 Note Added: 0009926
2017-08-19 11:30 Kunda1 Additional Information Updated View Revisions
2017-08-19 11:30 Kunda1 Status new => confirmed
2017-08-19 12:54 Kunda1 Note Added: 0009954
2017-08-19 12:54 Kunda1 Target Version => 0.17
2017-08-19 13:37 Kunda1 Relationship added related to 0002567
2017-08-19 13:39 Kunda1 Note Added: 0009956
2017-09-25 09:31 wmayer Status confirmed => closed
2017-09-25 09:31 wmayer Resolution open => fixed
2017-09-25 09:31 wmayer Fixed in Version => 0.17
2017-09-25 09:31 wmayer Note Added: 0010184