View Issue Details

IDProjectCategoryView StatusLast Update
0003150PartDesignBugpublic2018-01-30 18:08
ReporterickbyAssigned Toickby 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003150: App::Part: Delete and undo bugs
Descriptionhttps://forum.freecadweb.org/viewtopic.php?f=10&p=185507#p185478

Steps To ReproduceIssue No. 2: (Fixed)
1. Create a new document and activate the Part Design workbench.
2. Add a new Body.
3. Create an additive box attached to the XY plane of the body.
4. Activate the part workbench and create a mirror of the Body about the YZ plane with the part mirroring feature.
5. Add a new Part and drag the part mirroring feature into it.
6. Delete the part mirroring feature. The Body is now shown at the document level and you can't drag it back into the Part.

Issue No. 3: (Fixed)
1. Create a new document and activate the Part Design workbench.
2. Add a new Part.
3. Click "Create Body" so that it is added to the active Part.
4. Create an additive box attached to the XY plane of the body.
5. Activate the part workbench and create a mirror of the Body about the YZ plane with the part mirroring feature.
6. The mirror feature shows "Links go out of the allowed scope." This makes sense because it is at the document level.
7. Drag the mirror feature into the Part (because it let me do this in issue 0000002), but nothing changes.
8. Undo until before the mirror feature was created or delete the mirror feature. The Body is not shown in the tree view but it is still shown in the 3d view.

Issue No. 4
1. Create a new document and activate the part workbench.
2. Create a Cube, Cylinder, and Sphere.
3. Create a fusion of the Cube and Cylinder and a fusion of the Cylinder and the Sphere (so that the cylinder has two parents).
4. Create a Part and drag both of the fusions into it.
5. Create a new Part and drag one of the fusions into it.
6. Undo results in Exception: Object can only be in a single GeoFeatureGroup and you can't undo past it.
TagsNo tags attached.

Activities

wmayer

2017-09-13 10:54

administrator   ~0010108

https://github.com/FreeCAD/FreeCAD/commit/946e470a6f3952c321822cc8c867ba073ef16d68
fixes the first and second issue. But the last issue is not fixed yet.

wmayer

2017-09-21 10:56

administrator   ~0010144

https://github.com/FreeCAD/FreeCAD/commit/957b23e6109d3cf297fa437a4002a333321315bc fixes now the exception that has been raised in Issue No. 4.

However, a new error occurs now: when pressing the undo button the cube, cylinder and sphere also appear directly inside the Part container. This doesn't seem logical.

ickby

2017-09-21 11:43

developer   ~0010147

Did you check the behaviour after https://github.com/FreeCAD/FreeCAD/commit/94248a6c4201720e27d98ef54f54350171101b32 ?

This should fix the "cylinder and sphere in Part container" problem.

plgarcia

2018-01-08 20:25

reporter   ~0010731

There are many situations where undo do not work. There are many situations where undo is not implemented at all, for example any change in data panel or in view panel (position colors), the replace tool in OpenScad workbench.
In these cases undo undelete the previous operation. In the case of replace tool, the undo may lead to complete mess of the scene.

wmayer

2018-01-30 18:08

administrator   ~0010901

All reported issues of this ticket are fixed now.

Issue History

Date Modified Username Field Change
2017-08-07 06:04 ickby New Issue
2017-08-07 06:04 ickby Status new => assigned
2017-08-07 06:04 ickby Assigned To => ickby
2017-09-13 10:54 wmayer Note Added: 0010108
2017-09-13 12:09 Kunda1 Steps to Reproduce Updated View Revisions
2017-09-21 10:56 wmayer Note Added: 0010144
2017-09-21 11:43 ickby Note Added: 0010147
2018-01-08 20:25 plgarcia Note Added: 0010731
2018-01-30 18:08 wmayer Status assigned => closed
2018-01-30 18:08 wmayer Resolution open => fixed
2018-01-30 18:08 wmayer Fixed in Version => 0.17
2018-01-30 18:08 wmayer Note Added: 0010901