View Issue Details

IDProjectCategoryView StatusLast Update
0000315FreeCADBugpublic2011-03-21 09:12
ReporternormandcAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target Version0.12Fixed in Version0.12 
Summary0000315: New Circle tool in Sketcher causes problems editing Pad and Pocket features
DescriptionThe new circle tool in Sketcher causes instability with Pad and Pocket commands when editing their extrusion length.

Case 1 (Pad) - start a sketch, draw a circle, create pad. On pad feature, change length to any dimension: the solid reverts to a surface cylinder opened on both ends.

Case 2 (Pocket) - on an existing solid shape built with pad feature and any sketch drawing tool, select a face, start a sketch and draw a circle. Use the pocket command. Modifying the length of the pocket hangs FreeCAD indefinitely.
Additional InformationFreeCAD 0.12.4285 from /trunk on Ubuntu 10.04.2 LTS 64-bit
TagsNo tags attached.

Activities

normandc

2011-03-20 20:11

manager   ~0000741

Wanted to downgrade severity of the bug to minor but I'm not allowed to modify it.

BTW a 0.12 series should be added to the bug report form.

Jriegel

2011-03-21 07:58

administrator   ~0000742

I see this error, strange!

wmayer

2011-03-21 08:06

administrator   ~0000743

Yes, I can confirm both issues on Windows 7 64-bit.

The first issue seems to be a problem with OCC's class BRepPrimAPI_MakePrism. But if go to edit mode and move the circle a little bit and recompute it the pad is fine again.

wmayer

2011-03-21 08:17

administrator   ~0000744

The hanging happens inside BRepAlgoAPI_Cut which is called in Pocket::execute()

wmayer

2011-03-21 09:06

administrator   ~0000746

This is definitely a bug in OCC but I found a nice work around. The point is that when re-computing the shape the missing parts of the cylinder have no valid tessellation and thus they appear empty. They only have a wire. And this is a direct consequence for the hanging of the pocket because the cut algorithm tries to compute the cut with a partially invalid shape.

The solution is to make a copy of the sketch shape and use the copy.

Issue History

Date Modified Username Field Change
2011-03-20 20:09 normandc New Issue
2011-03-20 20:11 normandc Note Added: 0000741
2011-03-21 07:58 Jriegel Note Added: 0000742
2011-03-21 07:58 Jriegel Assigned To => Jriegel
2011-03-21 07:58 Jriegel Status new => acknowledged
2011-03-21 07:59 Jriegel Product Version => trunk
2011-03-21 08:06 wmayer Note Added: 0000743
2011-03-21 08:06 wmayer Assigned To Jriegel =>
2011-03-21 08:06 wmayer Status acknowledged => new
2011-03-21 08:17 wmayer Note Added: 0000744
2011-03-21 09:06 wmayer Note Added: 0000746
2011-03-21 09:07 wmayer Assigned To => wmayer
2011-03-21 09:07 wmayer Status new => closed
2011-03-21 09:07 wmayer Resolution open => fixed
2011-03-21 09:07 wmayer Fixed in Version => trunk
2011-03-21 09:07 wmayer Target Version => trunk
2011-03-21 09:12 wmayer Fixed in Version trunk => 0.12
2011-03-21 09:12 wmayer Target Version trunk => 0.12