View Issue Details

IDProjectCategoryView StatusLast Update
0003136Part[FreeCAD] Featurepublic2017-08-11 11:54
ReporterHoWil Assigned Towmayer  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0003136: add element to existing compound
DescriptionOne can't add new elements to an existing compound in part-wb. This is possible e.g. for the fusion operation.
But, one can add or remove elements by drag-and-drop to a fusion or boolean-fragments .
Please see the attached example where I would like to add the 'Sphere' by drag-n-drop to the 'Compound'.

See also the related discussion in the forum:
https://forum.freecadweb.org/viewtopic.php?p=183565#p183565
Steps To ReproduceCreate three objects in part-wb. E.g. a cylinder, a box and a sphere.
Make a compound of two of the three.
Drag the third element into the compound.
This is in contrast to a fusion or boolean-fragments not allowed.
Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11622 (Git)
Build type: None
Branch: master
Hash: 5ffe17153d84e5b361ba4c41e56c62977619f589
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: German/Austria (de_AT)
TagsPart
FreeCAD Information

Relationships

related to 0002498 closedwmayer Part Compound: add or remove objects 

Activities

HoWil

2017-07-23 17:17

developer  

FC_part-wb_change_compound.fcstd (9,738 bytes)

silopolis

2017-08-05 05:58

reporter   ~0009875

Hi, think this a duplicate of 0002498... and really need this feature too !

wmayer

2017-08-11 10:57

administrator   ~0009886

https://github.com/FreeCAD/FreeCAD/commit/d84c2d354447dbbcbbbd4915ec4c95a0c9fe79e1

Kunda1

2017-08-11 11:54

administrator   ~0009888

c:FreeCAD:d84c2d354447:

Issue History

Date Modified Username Field Change
2017-07-23 17:17 HoWil New Issue
2017-07-23 17:17 HoWil File Added: Bildschirmfoto von »2017-07-22 19-36-56«.png
2017-07-23 17:17 HoWil File Added: FC_part-wb_change_compound.fcstd
2017-07-23 17:17 HoWil Tag Attached: Part
2017-07-23 17:21 HoWil Description Updated View Revisions
2017-07-23 17:21 HoWil Steps to Reproduce Updated View Revisions
2017-08-05 05:58 silopolis Note Added: 0009875
2017-08-05 13:09 Kunda1 Relationship added related to 0002498
2017-08-11 10:57 wmayer Assigned To => wmayer
2017-08-11 10:57 wmayer Status new => closed
2017-08-11 10:57 wmayer Resolution open => fixed
2017-08-11 10:57 wmayer Fixed in Version => 0.17
2017-08-11 10:57 wmayer Note Added: 0009886
2017-08-11 11:54 Kunda1 Note Added: 0009888