View Issue Details

IDProjectCategoryView StatusLast Update
0003100Path[FreeCAD] Bugpublic2017-08-13 15:21
ReporterKonstantinAssigned Tosliptonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0003100: Different behavior of Clearance parameter in Face milling
DescriptionIn attached file you can see three tools are used. Don't know why, but Face mill tool sets it's Clearance to 10.0. Other tools sets to 35.0. Face mill is doing it wrong. Attached generated code to.
Steps To ReproduceTo reproduce - in my file I create Job, Change tool to face mill, press Facing operation button, press Ok. Clearance is set to 10, which in fact will be inside of my blank.
Additional InformationOS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11432 (Git)
Build type: Release
Branch: master
Hash: 0768ae99cfd6036601f66658f6e0f923de9af6f2
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.1.0
TagsNo tags attached.

Activities

Kunda1

2017-06-24 11:29

administrator   ~0009508

Last edited: 2017-06-24 11:39

View 2 revisions

Missing attachment + has duplicate 3101,3102 (edit: I've deleted those tickets now)

Kunda1

2017-06-24 11:30

administrator   ~0009509

@Konstantin thx for your bug reports please familiarize yourself with how to report bugs in FC http://forum.freecadweb.org/viewtopic.php?f=3&t=5236

Kunda1

2017-06-24 11:38

administrator   ~0009510

Changed from 'patch' to 'bug'

Konstantin

2017-06-24 11:39

reporter   ~0009511

Sorry, I couldn't attach my file (it says something "file does not exists"), and didn't know, that it still posts my bug. Why is that? Wrong file format? To big? Or it's just because my connection lagging today?

I have wrote the bug submission guideline but didn't found anything about it.

Sorry, once again.

Konstantin

2017-06-24 11:41

reporter   ~0009512

Last edited: 2017-06-24 11:43

View 2 revisions

Here's full text
Someone wrote

Invalid upload path. Directory either does not exist or not writable to webserver.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.


Kunda1

2017-06-24 11:42

administrator   ~0009513

@konstantin no worries, per FC guidelines we encourage opening a thread first to discuss the issue with the community. Many issues get resolved that way before needing to be posted to the tracker. There is a size limit on attachments in the tracker, if you exceed it you can always upload to s third party cloud-like service and link to it from the ticket.

Kunda1

2017-06-24 11:44

administrator   ~0009514

@konstantin thanks for reporting that. Looks like a tracker problem. CC @kkremitzki

Konstantin

2017-06-24 11:52

reporter   ~0009515

Sorry, created a thred in forum with attachments. Here it is

sliptonic

2017-06-24 13:56

developer   ~0009518

Confirmed. If PathMillFace is working on the entire solid, it doesn't guess at depths correctly. It uses a unique logic. I'll probably fix this in two steps. First a quick hack to get the clearance height right.

The better solution is to move the setDepths logic used in other operations into the PathUtils module and have it return a depth_params object which the operations can then use to set their starting values. setDepths needs to be expanded a bit to handle subelement selection though.

sliptonic

2017-06-29 18:44

developer   ~0009615

FreeCAD Pull Request 847

Kunda1

2017-08-13 15:21

administrator   ~0009900

Closing

Issue History

Date Modified Username Field Change
2017-06-24 11:24 Konstantin New Issue
2017-06-24 11:29 Kunda1 Note Added: 0009508
2017-06-24 11:30 Kunda1 Note Added: 0009509
2017-06-24 11:38 Kunda1 Category Patch => Bug
2017-06-24 11:38 Kunda1 Note Added: 0009510
2017-06-24 11:39 Konstantin Note Added: 0009511
2017-06-24 11:39 Kunda1 Note Edited: 0009508 View Revisions
2017-06-24 11:41 Konstantin Note Added: 0009512
2017-06-24 11:42 Kunda1 Note Added: 0009513
2017-06-24 11:43 Kunda1 Note Edited: 0009512 View Revisions
2017-06-24 11:44 Kunda1 Note Added: 0009514
2017-06-24 11:52 Konstantin Note Added: 0009515
2017-06-24 13:56 sliptonic Note Added: 0009518
2017-06-24 13:56 sliptonic Assigned To => sliptonic
2017-06-24 13:56 sliptonic Status new => assigned
2017-06-29 18:44 sliptonic Status assigned => resolved
2017-06-29 18:44 sliptonic Resolution open => fixed
2017-06-29 18:44 sliptonic Note Added: 0009615
2017-08-13 15:21 Kunda1 Status resolved => closed
2017-08-13 15:21 Kunda1 Fixed in Version => 0.17
2017-08-13 15:21 Kunda1 Note Added: 0009900