View Issue Details

IDProjectCategoryView StatusLast Update
0000031FreeCADBugpublic2009-11-06 17:17
Reportertdalla Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000031: Compilation run properly but program crash when creating a new document
DescriptionHi,
Here's my configuration:
Linux Debian squeeze (testing) kernel 2.6.30-2-686
The compilation of the svn version (FreeCAD 0.9, Libs: 0.9R2237) run without any problem using cmake.
When I start the program, everything looks ok (splash + interface) BUT, when I create a new document, FreeCAD crash with the following message:

FreeCAD: ../../src/xcb_io.c:542: _XRead: Assertion `dpy->xcb->reply_data != ((void *)0)' failed.
Abnormal program termination...

Don't hesitate if you require aditionnal information

Cheers,

      Thomas
TagsNo tags attached.
FreeCAD Information

Activities

Jriegel

2009-11-03 20:31

administrator   ~0000022

Could you try to build with automake?
The cMake support for Linux is not very stable so far.

2009-11-04 20:17

 

FreeCad_Configure.out (Attachment missing)

tdalla

2009-11-04 20:19

reporter   ~0000025

I tried right now but the problem remains. I have joint the configure output.

Jriegel

2009-11-06 14:09

administrator   ~0000028

Were is the output?

Jriegel

2009-11-06 17:17

administrator   ~0000029

Works for me.
I compiled it completely on Squeeze and used the freecad packages
both works.
There is a minor problem in Complete and Pivy but you can always open
a document....

juergen

Issue History

Date Modified Username Field Change
2009-11-02 18:26 tdalla New Issue
2009-11-03 20:31 Jriegel Note Added: 0000022
2009-11-03 20:35 Jriegel Status new => feedback
2009-11-04 20:17 tdalla File Added: FreeCad_Configure.out
2009-11-04 20:19 tdalla Note Added: 0000025
2009-11-06 14:09 Jriegel Note Added: 0000028
2009-11-06 17:17 Jriegel Note Added: 0000029
2009-11-06 17:17 Jriegel Status feedback => closed
2009-11-06 17:17 Jriegel Resolution open => unable to reproduce