View Issue Details

IDProjectCategoryView StatusLast Update
0000308FreeCADBugpublic2011-03-29 19:53
Reporterwmayer Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.12Fixed in Version0.12 
Summary0000308: Exported dxf totally broken when re-importing
DescriptionAccording to the forum thread the exported dxf file is completely broken because everything lies in a common plane.
TagsNo tags attached.
FreeCAD Information

Relationships

child of 0000151 closedyorik support 3DFACES in dxf import & export 

Activities

wmayer

2011-03-13 15:26

administrator   ~0000729

Here you'll find the tested example http://www.file-upload.net/download-3281126/packen.zip.html
The file is too big to upload it to Mantis so I give only the url here.

normandc

2011-03-13 17:50

manager   ~0000730

I guess this is the forum thread:
http://forum.freecadweb.org/viewtopic.php?f=13&t=858

yorik

2011-03-14 22:58

administrator   ~0000734

Okay thanks for telling me, I hadn't looked at the german topic :)
I'll have a look ASAP

yorik

2011-03-14 23:11

administrator   ~0000735

Hm for me the .fcstd file crashes on opening... The dxf file imports fine, though.
Is the fact that everything gets "flattened" that is wrong? Because that is not a bug, it's a feature :)

More seriously, the dxf format is pretty bad for working with complex 3D, the only "free" way to write 3D objects in dxf format is to use prehistoric 3DFACE elements (The "real" 3D data of a dxf file is a big block of encoded SAT data, which is not free neither documented). At the moment, the dxf exporter assumes you will work with 2D only, and everything gets flattened indeed (same as what the blender dxf exporter does).

I have plans to add 3DFACE support ( see 0000151 ) but that's probably the best I'll be able to do...

Can someone else see if the .fcstd file crashes with latest freecad revision? (The file itself is valid because it can be unzipped and the thumbnail extracted)

yorik

2011-03-29 19:53

administrator   ~0000756

Draft preferences now have an option to export 3D geometry as 3D polyfaces, allowing a more-or-less decent DXF 3D support. Note that all objects will be transformed into meshes, though. This is unavoidable unless some open ACIS .SAT data parser becomes available.

Feel free to reopen this if something can be bettered in the current implementation...

Issue History

Date Modified Username Field Change
2011-03-13 15:23 wmayer New Issue
2011-03-13 15:23 wmayer Status new => assigned
2011-03-13 15:23 wmayer Assigned To => yorik
2011-03-13 15:26 wmayer Note Added: 0000729
2011-03-13 17:50 normandc Note Added: 0000730
2011-03-14 22:58 yorik Note Added: 0000734
2011-03-14 23:11 yorik Note Added: 0000735
2011-03-14 23:12 yorik Relationship added child of 0000151
2011-03-29 19:53 yorik Note Added: 0000756
2011-03-29 19:53 yorik Status assigned => closed
2011-03-29 19:53 yorik Resolution open => fixed
2011-03-29 19:53 yorik Fixed in Version => 0.12