View Issue Details

IDProjectCategoryView StatusLast Update
0003079SketcherBugpublic2017-06-18 16:23
ReporterPaFe Assigned Toabdullah  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003079: Auto overconstraint drawing a line on a linked edge
DescriptionWhen sketching something on a face of an existing body it is very useful to select edges of the body so that the new sketch can be constrainted to it using "create edge linked to external geometry".

Unfortunately, when (in the new sketch) I try to draw a line over the linked edge, Freecad automatically creates coincident constraints for the end points of the new line over the edge, but also a vertical or horizontal constraint (because also the edge was vertical or horizontal). This overconstraints the line.

This issue can be manually solved by removing the vertical or horizontal constraint but it clearly is not the normal behaviour it should have.
Tagsconstraints
FreeCAD Information

Activities

PaFe

2017-06-09 11:52

reporter   ~0009317

This is a more general bug, the same thing happens also drawing a line in a clear sketch from the center point to a point over the horizontal or the verticar axis.

Kunda1

2017-06-09 15:47

administrator   ~0009318

@PaFe what version of FC are you referring to? Help > About FreeCAD

PaFe

2017-06-09 17:36

reporter   ~0009319

@Kunda1 both 0.16 from the official ppa and 0.17 appimage. I add a screenshot of the situation

Kunda1

2017-06-09 21:49

administrator   ~0009321

@PaFe thanks. Though please get in to the habit of posting your full freecad versions (Help > About FreeCAD > Copy to clipboard) when seeking any kind of help or opening a ticket. It seriously cuts down on extra bug triaging steps.
@abdullah this looks solver related, mind on offering any feedback?

abdullah

2017-06-10 04:57

manager   ~0009328

@kunda1

It is not a solver issue, but it is a sketcher issue. It has been a long standing complaint in the forum. I just got an idea, let's see if I find some time to implement it...

PaFe

2017-06-10 07:59

reporter   ~0009329

@Kunda1 So sorry, it was my first report, I will pay more attention in the future
@abdullah Great, thank you so much

abdullah

2017-06-10 11:07

manager   ~0009330

Last edited: 2017-06-10 11:07

View 2 revisions

The reason for the feature is:

Not it is not a bug, because there are cases where this constraint is needed. They involve importing the external geometry, retracing over it, deleting the external geometry to avoid having a break point due to lack of toponaming. Part of this use case is currently given by carbon copy, however not everything has a starting sketch.

However, it is acknowledged that there should be two operating modes, one as the reporter indicates and one like legacy.

PaFe

2017-06-10 13:39

reporter   ~0009334

@abdullah The issue happens also with sketch standard axis (as showed in the screenshot in a previous note), in this case should be a bug.
In order to have two operating modes the solution can be adding the constraint "hidden" and then, deleting the previous geometry the constraint comes out.
Anyway, in my opinion it could be better to don't add another "vertical" or "horizontal" constraint when the same constraint it given from external geometry. Then in case the external geometry has to be deleted, an underconstrainted sketch is even better to manage than an overconstrainted one.

abdullah

2017-06-10 15:07

manager   ~0009335

@PaFe

ok, with the axis it should be a minor bug, I agree.

I have already some working code for single lines. Polylines is more complicated as they have their own specific code to handle transitions. I will give it a look later today or tomorrow.

As for the mode, it will be a checkbox in the editor settings, "Avoid redundants autoconstraints" (by default enabled).

PaFe

2017-06-10 15:19

reporter   ~0009336

@abdullah Very well, the checkbox could be a great solution! Thank you

abdullah

2017-06-10 23:05

manager   ~0009338

PR:
https://github.com/FreeCAD/FreeCAD/pull/813

Forum:
https://forum.freecadweb.org/viewtopic.php?f=10&t=22889

wmayer

2017-06-18 16:23

administrator   ~0009450

https://github.com/FreeCAD/FreeCAD/commit/25a28b08519b5aa16ac0507cb585e4b5e382452c

Issue History

Date Modified Username Field Change
2017-06-09 10:40 PaFe New Issue
2017-06-09 11:52 PaFe Note Added: 0009317
2017-06-09 15:47 Kunda1 Note Added: 0009318
2017-06-09 17:36 PaFe File Added: Screenshot_20170609_193436.png
2017-06-09 17:36 PaFe Note Added: 0009319
2017-06-09 21:43 Kunda1 Tag Attached: Solver
2017-06-09 21:49 Kunda1 Note Added: 0009321
2017-06-10 04:57 abdullah Assigned To => abdullah
2017-06-10 04:57 abdullah Status new => confirmed
2017-06-10 04:57 abdullah Note Added: 0009328
2017-06-10 07:59 PaFe Note Added: 0009329
2017-06-10 11:04 abdullah Severity major => minor
2017-06-10 11:04 abdullah Category Bug => Feature
2017-06-10 11:07 abdullah Note Added: 0009330
2017-06-10 11:07 abdullah Note Edited: 0009330 View Revisions
2017-06-10 11:37 Kunda1 Tag Detached: Solver
2017-06-10 11:38 Kunda1 Tag Attached: constraints
2017-06-10 13:39 PaFe Note Added: 0009334
2017-06-10 15:07 abdullah Note Added: 0009335
2017-06-10 15:07 abdullah Category Feature => Bug
2017-06-10 15:19 PaFe Note Added: 0009336
2017-06-10 23:05 abdullah Note Added: 0009338
2017-06-18 16:23 wmayer Status confirmed => closed
2017-06-18 16:23 wmayer Resolution open => fixed
2017-06-18 16:23 wmayer Fixed in Version => 0.17
2017-06-18 16:23 wmayer Note Added: 0009450