View Issue Details

IDProjectCategoryView StatusLast Update
0003075Part[FreeCAD] Bugpublic2017-09-25 09:55
ReporterSamAssigned Tovejmarie 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi7OSubuntuOS Version16.04
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0003075: Crash resizing primitive in Part (due to VBO being enabled)
DescriptionOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11232 (Git)
Build type: None
Branch: master
Hash: 5f54fc0298cea749c53fa3c1a6be71f1f1e1476f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0



Steps To ReproduceStart freecad
New file using toolbar icon
part>primitives>cube
select cube
click in length
type 100
type <tab>

crash. every time.
Additional Informationhave crash report, but couldn't be arsed pastebinning it. will cooperate further if needed.
TagsPart, VBO

Activities

Kunda1

2017-06-06 18:45

administrator   ~0009298

@chrisb please test this as well if you don mind, thanks!

chrisb

2017-06-07 16:20

developer   ~0009307

I can reproduce the problem here with a slightly newer version if and only if VBO is enabled. If it is disabled everything is ok.

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11241 (Git)
Build type: None
Branch: master
Hash: 3c96803d12006411f4563d149fa4f81a1a5993ac
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0

Sam

2017-06-07 21:23

reporter   ~0009310

This crash doesn't happen for me either if I disable VBO.

Thanks to wmayer for suggesting this over at this thread

wmayer

2017-09-25 09:55

administrator   ~0010186

This should be fixed now for a couple of weeks.

Issue History

Date Modified Username Field Change
2017-06-06 02:34 Sam New Issue
2017-06-06 02:34 Sam Tag Attached: Part
2017-06-06 18:45 Kunda1 Note Added: 0009298
2017-06-07 16:20 chrisb Note Added: 0009307
2017-06-07 20:59 Kunda1 Status new => confirmed
2017-06-07 21:00 Kunda1 Target Version => 0.17
2017-06-07 21:23 Sam Note Added: 0009310
2017-08-19 12:59 Kunda1 Tag Attached: VBO
2017-08-28 20:07 Kunda1 Summary Crash resizing primitive in Part => Crash resizing primitive in Part (due to VBO being enabled)
2017-09-25 09:55 wmayer Assigned To => vejmarie
2017-09-25 09:55 wmayer Status confirmed => closed
2017-09-25 09:55 wmayer Resolution open => fixed
2017-09-25 09:55 wmayer Fixed in Version => 0.17
2017-09-25 09:55 wmayer Note Added: 0010186