View Issue Details

IDProjectCategoryView StatusLast Update
0003048Path[FreeCAD] Bugpublic2017-07-18 16:07
ReportermlampertAssigned Tosliptonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0003048: Individual Path visibility not maintained across restarts
DescriptionLoading a document makes all individual Path features (like a Contour or Profile) visible, regardless of their state when the document was saved. In order to hide a Path it is currently necessary to set visibility of the feature in question /and/ its Job to false - only the Job's setting is restored when the document is loaded.
TagsNo tags attached.

Activities

mlampert

2017-05-28 01:15

developer   ~0009175

Some more observations ...

it seems the visibility is properly maintained after all. Loading a file restores all individual Path's visibility setting the way they were saved. However each one of them requires a recompute (not sure why) - and the recompute sets the Path to visible.

This can easily be verified by setting the visibility of a Path to false, then "Mark to recompute" and finally pressing the recomupte button.

sliptonic

2017-07-08 16:45

developer   ~0009688

I can't duplicate this. Are you still seeing it? I've tested with both the recompute method and the save/restore and it seems to be preserving state for me.

mlampert

2017-07-08 17:48

developer   ~0009691

The behaviour has slightly changed. Visibility seems to be maintained during save/restore. However, an individual Path will make itself visible whenever it is recomputed.

* turn visibility of a profile off
* mark to recompute
* recompute
-> profile is visible again

This is a different issue as the original one - we can close this on and create a new one or keep this one.

sliptonic

2017-07-11 23:14

developer   ~0009723

FreeCAD Pull Request 865

Related Changesets

FreeCAD: master 48337e03

2017-07-08 15:16:03

sliptonic


Committer: Yorik van Havre Details Diff
Path: fix 0003048 Visibility on recompute is now preserved Affected Issues
0003048
mod - src/Mod/Path/PathScripts/PathDrilling.py Diff File
mod - src/Mod/Path/PathScripts/PathEngrave.py Diff File
mod - src/Mod/Path/PathScripts/PathMillFace.py Diff File
mod - src/Mod/Path/PathScripts/PathPocket.py Diff File
mod - src/Mod/Path/PathScripts/PathProfile.py Diff File
mod - src/Mod/Path/PathScripts/PathProfileEdges.py Diff File

Issue History

Date Modified Username Field Change
2017-05-26 21:32 mlampert New Issue
2017-05-28 01:15 mlampert Note Added: 0009175
2017-07-08 16:45 sliptonic Note Added: 0009688
2017-07-08 17:48 mlampert Note Added: 0009691
2017-07-11 23:14 sliptonic Assigned To => sliptonic
2017-07-11 23:14 sliptonic Status new => closed
2017-07-11 23:14 sliptonic Resolution open => fixed
2017-07-11 23:14 sliptonic Fixed in Version => 0.17
2017-07-11 23:14 sliptonic Note Added: 0009723
2017-07-18 16:07 Kunda1 Changeset attached => FreeCAD master 48337e03