View Issue Details

IDProjectCategoryView StatusLast Update
0003034Path[FreeCAD] Bugpublic2017-11-26 00:52
ReporterJakob Lundberg Assigned Tomlampert  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0003034: HoldingTags dressup adds move to origin
DescriptionThe HoldingTags dressup adds a move to origin at the begining of the operation. This is not present when doing a normal profile operation and should not be necessary.
Steps To Reproduce1. Create two bodies
2. Add profiling operations to the bodies
3. Add HoldingTags dressup to the operations

Result:
After the first profiling operation the spindle will return to origin.
Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11084 (Git)
Build type: None
Branch: master
Hash: fa00b4f06a0c96de57a777d6532467dfd8e5d141
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
TagsNo tags attached.
FreeCAD Information

Activities

Jakob Lundberg

2017-05-16 07:52

reporter  

return_to_origin.png (266,327 bytes)
return_to_origin.png (266,327 bytes)

Kunda1

2017-05-16 11:53

administrator   ~0009030

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=15&t=22429

mlampert

2017-11-21 06:16

developer   ~0010448

The issue is that the dressup converts the base g-code to edges. G-code does not have a defined starting point, but edges do. The first move of each op is typically a G0 to ClearanceHeight (no X or Y coordinates specified). For the edge 0 is used and then when transforming back to g-code the X and Y coordinates are used in the command.

mlampert

2017-11-22 18:35

developer   ~0010457

https://github.com/FreeCAD/FreeCAD/pull/1106/commits/8985372d1afa38ac1657f45e0a45858dea759f27

Kunda1

2017-11-26 00:51

administrator   ~0010472

Committed in c:FreeCAD:737ca980f6e5c06f09020a7fb2c55f0059c2f4d4:

Issue History

Date Modified Username Field Change
2017-05-16 07:52 Jakob Lundberg New Issue
2017-05-16 07:52 Jakob Lundberg File Added: return_to_origin.png
2017-05-16 11:53 Kunda1 Note Added: 0009030
2017-11-21 06:11 mlampert Assigned To => mlampert
2017-11-21 06:11 mlampert Status new => assigned
2017-11-21 06:16 mlampert Note Added: 0010448
2017-11-22 18:35 mlampert Status assigned => resolved
2017-11-22 18:35 mlampert Resolution open => fixed
2017-11-22 18:35 mlampert Fixed in Version => 0.17
2017-11-22 18:35 mlampert Note Added: 0010457
2017-11-26 00:51 Kunda1 Note Added: 0010472
2017-11-26 00:52 Kunda1 Status resolved => closed